cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
simms7400
Post Prodigy
Post Prodigy

Why isn't Coalesce working?

Hi Folks -

 

I have an field (Asset ID) I do not display to the end user at any time as it's just a unique I populate with an MS Access VBA routine after submission. However, I upon intial submission, I populate it with whatever is available in the Alias field (Asset Alias).  Recently, I found out this wasn't working...

 

I would expect the value of Asset Alias to be in Asset ID:

asset.jpg

 

Here is my Defauly propety of Asset ID:

Coalesce(ThisItem.Name,ThisItem.Alias)

 

Keep in mind,  Name = Asset ID and Alias = Asset Alias.

 

Would anyone know why this isn't working? I even tried to reference another field and it still doesn't work.


Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions
v-xida-msft
Community Support
Community Support

Hi @simms7400 ,

Based on the issue that you mentioned, I think there is somethin wrong with your formula.

 

Before you submit a new record (intial submission), the ThisItem.Name and ThisItem.Alias formula in your Edit form (in New mode) would both return blank. So the Coalesce() function within your app would return blank.

 

I have made a test on my side, please take a try with the following workaround:

Set the Default propety of Asset ID to following:

Coalesce(ThisItem.Name, EditForm1.Updates.Alias)

or

Coalesce(ThisItem.Name, AssetAliasTextBox.Text)

Note: The EditForm1 represents the Edit form in your app. The AssetAliasTextBox represents the Text Input box within the Asset Alias data card.

 

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

2 REPLIES 2
v-xida-msft
Community Support
Community Support

Hi @simms7400 ,

Based on the issue that you mentioned, I think there is somethin wrong with your formula.

 

Before you submit a new record (intial submission), the ThisItem.Name and ThisItem.Alias formula in your Edit form (in New mode) would both return blank. So the Coalesce() function within your app would return blank.

 

I have made a test on my side, please take a try with the following workaround:

Set the Default propety of Asset ID to following:

Coalesce(ThisItem.Name, EditForm1.Updates.Alias)

or

Coalesce(ThisItem.Name, AssetAliasTextBox.Text)

Note: The EditForm1 represents the Edit form in your app. The AssetAliasTextBox represents the Text Input box within the Asset Alias data card.

 

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Hi - Worked like a charm - thank you!!

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Users online (1,055)