cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Frequent Visitor

Wrong validation behaviour when creating SharePoint list items with required columns and ContentTypes?

I'm trying to build a PowerApps based Canvas Apps which communicates with SharePoint.


In SharePoint I have a ContentType enabled list and I added one custom column 'TestCol1' as required column. This column is used only in one of the various ContentTypes (e.g. ContentType1).
When using SharePoint to create a new ListItem, it is possible to add new items without providing values for 'TestCol1'. An value for 'TestCol1' is only required if the ContentType is set to ContentType1.
I also tried to use GraphAPI and the behaviour is the same.

 

But in PowerApps I always have to supply a value for 'TestCol1' regardles of the ContentType. Is this a bug?

 

As a workaround I could use custom columns not marked as 'equired and only set them to required in the using ContentTypes. But unfortunatly it does not seems to be possible to change this for existing columns.

 

Any ideas? Thank you!

0 REPLIES 0

Helpful resources

Announcements
New Badges

New Solution Badges!

Check out our new profile badges recognizing authored solutions!

New Power Super Users

Congratulations!

We are excited to announce the Power Apps Super Users!

Power Apps Community Call

Power Apps Community Call: February

Did you miss the call? Check out the Power Apps Community Call here.

Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

Top Solution Authors
Top Kudoed Authors
Users online (50,765)