cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Regular Visitor

Yes/No field gets reset to default when going back to edit a saved form - Sharepoint List Forms

Hi,

 

I am still fairly new to powerapps so please try to make your answer simple, thanks 🙂

 

I have created a sharepoint list form using powerapps and have a few questions on the form that are set to only appear if the previous questions are marked "yes" (circled in screenshot 1)

 

This works just fine and dandy once the inital form is filled out and saved, but then when a user goes back to try and edit the form, the "yes/no" fields are now set back to "No" and the fields that were filled out are no longer visible. (seen in screenshot 2)

 

Can someone please assist me in figuring out why that could be?

 

Thank you!

 
 
 
 
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Support
Community Support

Re: Yes/No field gets reset to default when going back to edit a saved form - Sharepoint List Forms

Hi @dsmcwhir ,

Do you use "Yes/No" type column to store the question name in your SP List?

Do you control the Visible of other Data cards based on the "Yes/No" type field in your Edit form?

Further, do you change the Control Type of the "Yes/No" field data card into "Edit options" as below?

2.JPG

 

Based on the issue that you mentioned, I have made a test on my side, and don't have the issue that you mentioned. The "Yes/No" type field works well in my custom form app.

 

Please make sure the Update property of the "Yes/No" field data card in your Edit form to following:

If(
   RadioControl.Selected.Value = "Yes",
   true,
   RadioControl.Selected.Value = "No",
   false
)

set the Default property of the Radio control to following:

If(
   ThisItem.'Does the client still need to sign?' = true,
   "Yes",
   "No"
)

Note: The 'Does the client still need to sign?' represent the 'Yes/No' type field name in your SP List.

 

Please set the OnNew property of SharePointIntgeration control to following:

Refresh('Your SP List');
NewForm(SharePointForm1)

set the OnEdit property of SharePointIntegration control to following:

Refresh('Your SP List');
EditForm(SharePointForm1)

set the OnView property of SharePointIntegration control to following:

Refresh('Your SP List');
ViewForm(SharePointForm1)

then re-publish your custom form app to your SP list, then check if the issue is solved.

 

If the issue still exists, please consider remove the "Yes/No" type field data card from your Edit form, then re-add it again, then change the Control Type into "Edit Options" option as above screenshot, check if the issue still exists.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

5 REPLIES 5
Highlighted
Dual Super User II
Dual Super User II

Re: Yes/No field gets reset to default when going back to edit a saved form - Sharepoint List Forms

Hi @dsmcwhir 

 

There are known bugs with SharePoint Yes/No type columns

 

Check below links:

https://youtu.be/pn50AKn3Q1Y

http://rezadorrani.com/index.php/2019/04/14/powerapps-filter-sharepoint-yes-no-column-bug/

 

Avoid Yes/No columns !!!

 

--------------------------------------------------------------------------------
If this post helps answer your question, please click on “Accept as Solution” to help other members find it more quickly. If you thought this post was helpful, please give it a Thumbs Up.

Thanks,
Reza Dorrani, MVP
YouTube
Twitter

 

Highlighted
Community Support
Community Support

Re: Yes/No field gets reset to default when going back to edit a saved form - Sharepoint List Forms

Hi @dsmcwhir ,

Do you use "Yes/No" type column to store the question name in your SP List?

Do you control the Visible of other Data cards based on the "Yes/No" type field in your Edit form?

Further, do you change the Control Type of the "Yes/No" field data card into "Edit options" as below?

2.JPG

 

Based on the issue that you mentioned, I have made a test on my side, and don't have the issue that you mentioned. The "Yes/No" type field works well in my custom form app.

 

Please make sure the Update property of the "Yes/No" field data card in your Edit form to following:

If(
   RadioControl.Selected.Value = "Yes",
   true,
   RadioControl.Selected.Value = "No",
   false
)

set the Default property of the Radio control to following:

If(
   ThisItem.'Does the client still need to sign?' = true,
   "Yes",
   "No"
)

Note: The 'Does the client still need to sign?' represent the 'Yes/No' type field name in your SP List.

 

Please set the OnNew property of SharePointIntgeration control to following:

Refresh('Your SP List');
NewForm(SharePointForm1)

set the OnEdit property of SharePointIntegration control to following:

Refresh('Your SP List');
EditForm(SharePointForm1)

set the OnView property of SharePointIntegration control to following:

Refresh('Your SP List');
ViewForm(SharePointForm1)

then re-publish your custom form app to your SP list, then check if the issue is solved.

 

If the issue still exists, please consider remove the "Yes/No" type field data card from your Edit form, then re-add it again, then change the Control Type into "Edit Options" option as above screenshot, check if the issue still exists.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Highlighted
Super User III
Super User III

Re: Yes/No field gets reset to default when going back to edit a saved form - Sharepoint List Forms

Hi @dsmcwhir ,

Please have a read of this post I did yesterday on a similar issue.

This may not be a solution for you as it uses a collection, but it works as you retain the value of the control in the collection.

 

Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

Highlighted
Regular Visitor

Re: Yes/No field gets reset to default when going back to edit a saved form - Sharepoint List Forms

Hi @v-xida-msft ,

 

Thank you for the help. That solution worked and the "yes" answers are saving correctly now. However, I would like to know how to then make it so the default answer for those Yes/No questions is "No" when a new (blank) form is created. This is because I don't want the "signatory name" and "signatory email" fields to show by default. 

 

Thank you!

Highlighted
Community Support
Community Support

Re: Yes/No field gets reset to default when going back to edit a saved form - Sharepoint List Forms

Hi @dsmcwhir ,

Please consider set the Default property of the Radio control within your Edit form to following:

If(
  EditForm1.Mode = FormMode.New,             // add formula here to check if you are adding a new entry
  "No",
  If(
     ThisItem.'Does the client still need to sign?' = true,
     "Yes",
     "No"
  )
)

 

Please take a try with above solution, check if the issue is solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Watch Now

Experience what’s next for Power Apps

See the latest Power Apps innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (4,787)