cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Lalit_Kadam
Helper III
Helper III

add new line in string

Hi

I want to add new line sting which are displaying on label in power app.

In below code I am using char(10) but it is not working.

 

Concatenate("Hello ",lbl_approvervalidationlogic.Text,   ", "   ,Char(10) , "You have been selected as an approver")

 

Please note , using this code  to assign value in variable and label in canvas app.

 

Regards,

Lalit Kadam

 

1 ACCEPTED SOLUTION

Accepted Solutions
v-bofeng-msft
Community Support
Community Support

Hi @Lalit_Kadam :

Do you want to split a string into two lines?

I thought of a convenient method, that is to use the HTML Text control.We can use the <br> tag in the HTML Text control to achieve line breaks.

I've made a test for your reference:

1\Add a Html Text control:

HtmlText:

 

"Hello "&lbl_approvervalidationlogic.Text & ",<br>" & "You have been selected as an approver"

 

1.JPG

Best Regards,

Bof

View solution in original post

6 REPLIES 6
WarrenBelz
Super User
Super User

Hi @Lalit_Kadam ,

That should work as Text - you can also try Char(13), but I have tested as below

LabelTestBreak.png

Also if you are using this ultimately in an email body, try <br> instead. If you use Office365Outlook.SendEmailV2, it will automatically pick up and render the HTML line break.

 

Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

v-bofeng-msft
Community Support
Community Support

Hi @Lalit_Kadam :

Do you want to split a string into two lines?

I thought of a convenient method, that is to use the HTML Text control.We can use the <br> tag in the HTML Text control to achieve line breaks.

I've made a test for your reference:

1\Add a Html Text control:

HtmlText:

 

"Hello "&lbl_approvervalidationlogic.Text & ",<br>" & "You have been selected as an approver"

 

1.JPG

Best Regards,

Bof

Thanks @v-bofeng-msft ,

That is pretty much what I said.

Hi @Lalit_Kadam ,

Just checking if you got the result you were looking for on this thread. Happy to help further if not.

 

Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

Hi @Lalit_Kadam ,

I am following up this post to see if it can be closed if you obtained the result you were looking for.

Please click Accept as solution if my post helped you solve your issue as this will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

skydivertak
Frequent Visitor

I have found that if you target both browser and mobile, it seems that you need both Char(10) & "<br>" together.  The browser is ignoring the Char(10) and mobile (at least iOS) ignores the "<br>". I don't have Android or Windows PowerApps application.

Helpful resources

Announcements
2022 Release Wave 1 760x460.png

2022 Release Wave 1 Plan

Power Platform release plan for the 2022 release wave 1 describes all new features releasing from April 2022 through September 2022.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Top Solution Authors
Top Kudoed Authors
Users online (2,039)