cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
chris_cochrun
Level: Powered On

azure blob storage get file content

So, Im having an issue where I've stored the ID of each blob in a sql database and I'm then inserting that id into the AzureBlobStorage.GetFileContent method. Now, the images will load. Every time without fail, they load. However, on the phone, I get the error: 

AzureBlobStorage.GetFileContent failed: the method 'GetFileContent' has an invalid value for parameter 'id'.

 

but on the web, it doesn't show up. Here is the function I'm using to bring the image in.

 

AzureBlobStorage.GetFileContent(Image)

I don't understand why it seems to only have an issue on the phone, but not the web. Also, even on the phone, the images still come in. Also, all I'm doing is saving the ID of the blob in sql in the 'Image' column and then in the gallery that is displaying all the items of the sql table, I'm putting in this function for an image control.

 

Anyone got an idea why it seems to have an issue, but still renders the images? I feel like I can't let other people use this app if on every page I use the image their getting that big red error flying up.

1 ACCEPTED SOLUTION

Accepted Solutions
Spencer
Level: Powered On

Re: azure blob storage get file content

@chris_cochrunHey Chris this is an update to my previous post.  I think the whole issue I was experiencing with the getfilecontent 'Id' error that was happening just on the phone was linked to a type mismatch were I was using a GUID.  Here is a link to the article that solve this problem for me.  Experimental feature: Treat GUIDs as GUIDs  also GUIDs for Canvas apps graduate (With our latest release (3.19032) these features are now permanent.)

Look at the Experimental feature: Treat GUIDs as GUIDs that is now a built in activated feature.  It seems the timer delay I was using allowed enough time for the GUID to convert to a string before the error occured.  Hence using the GUID() function to convert eliminates the need for the timer.  I have only been using PowerApps for about six months so I am new to all this so please correct me if you see anything wrong.  I didn't want to pass misleading information on so I added this as a correction to my previus post.

 

 

View solution in original post

9 REPLIES 9
Community Support Team
Community Support Team

Re: azure blob storage get file content

Hi @chris_cochrun,

 

Could you please share a bit more about the error message on your side?

 

I think this issue is related to recent SQL connection issue within PowerApps. Currently, Apps with connections to SQL may be experiencing errors where data may not show up.

 

The PowerApps product team has been aware of the issue and are working on a fix. More details about the issue, please check following article:

https://powerapps.microsoft.com/en-us/support/

 

You could consider take a try to add a Label control within the Gallery control, then set the Text property to following ormula:

ThisItem.Image

then within your PowerApps Mobile App, check if the blob id could be shown up.

 

As an alternative solution, please take a try to turn off/disable the "Explicit Column selection" option within Advanced Settings of App settings (App settings-> Advanced settings-> "Explicit Column selection" option), then try your app within your Mobile device, check if the issue is solved.4.JPG

 

 

If the issue still exists, please take a try to uninstall PowerApps Mobile App from your Mobile device, and re-install it, then try your app again to check if the issue is solved.

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
chris_cochrun
Level: Powered On

Re: azure blob storage get file content

Well, the issue is not that the images aren't coming in. Because they are. I still get the id coming through when I use the

 

ThisItem.Image

in a label control.

 

But, it's just oddly still telling me there is an error while the images still load. So, technically I could ignore it because it's working, but I don't want a big red error flying up in front of the user on every page those images are used.

 

I tried uninstalling and reinstalling the app and still it popped up. Smiley Sad

 

Oh, and I've not been using the explicit column selection thing. I've had it off on this app because of some other issues it was causing.

Spencer
Level: Powered On

Re: azure blob storage get file content

Did any one find a solution to this issue I am experiencing the same issue on the phone and I also have tried the work around suggestions but still have the problem.Screenshot_PowerApps.jpg

 

chris_cochrun
Level: Powered On

Re: azure blob storage get file content

Hey @Spencer so, I finally discovered why mine was doing it. The table that held the id or path to the Azure Blob storage had some empty records and since every record is trying to seperately load a blob from Azure Blob storage, the records without images in them or rather the blob ids, were trying to load with empty strings and then I'd get that error. Instead, I've just preloaded all the blobs in a collection and their ids then connected them to the records by their ids. This means I'm only grabbing the ones that are actually in there and then when there isn't an id it simply just doesn't load.

Spencer
Level: Powered On

Re: azure blob storage get file content


@chris_cochrun wrote:

Hey @Spencer so, I finally discovered why mine was doing it. The table that held the id or path to the Azure Blob storage had some empty records and since every record is trying to seperately load a blob from Azure Blob storage, the records without images in them or rather the blob ids, were trying to load with empty strings and then I'd get that error. Instead, I've just preloaded all the blobs in a collection and their ids then connected them to the records by their ids. This means I'm only grabbing the ones that are actually in there and then when there isn't an id it simply just doesn't load.


@chris_cochrun thanks for the reply Chris!  I didn't have any empty records.  I tried preloading the data.  I tried a collection, SaveData, LoadData (so the data would be local on the device) I still get the error.  The only way I have found to work consistently is to use a timer and introduce a 1 second delay on the getfilecontent call.  With the timer delay it seems to work every time even if the data is not preloaded in a collection and just coming strait from the Azure SQL table.  The following below code is what worked (timer.ontimerend = Set(varGo,true) and the (<>) test stopped the empty record errors.

 

If(
AzureBlobID <> "" && varGo=true,
AzureBlobStorage.GetFileContent(ThisItem.AzureBlobID)
)

Spencer
Level: Powered On

Re: azure blob storage get file content

@chris_cochrunHey Chris this is an update to my previous post.  I think the whole issue I was experiencing with the getfilecontent 'Id' error that was happening just on the phone was linked to a type mismatch were I was using a GUID.  Here is a link to the article that solve this problem for me.  Experimental feature: Treat GUIDs as GUIDs  also GUIDs for Canvas apps graduate (With our latest release (3.19032) these features are now permanent.)

Look at the Experimental feature: Treat GUIDs as GUIDs that is now a built in activated feature.  It seems the timer delay I was using allowed enough time for the GUID to convert to a string before the error occured.  Hence using the GUID() function to convert eliminates the need for the timer.  I have only been using PowerApps for about six months so I am new to all this so please correct me if you see anything wrong.  I didn't want to pass misleading information on so I added this as a correction to my previus post.

 

 

View solution in original post

chris_cochrun
Level: Powered On

Re: azure blob storage get file content

Thanks @Spencer , glad you found a solution. Hopefully it may be of some use to others who may have a similar issue. I wasn't using any guids, but my previous post was my issue. Looks like we both have learned a little more about this platform! Man Happy

TimOates
Level: Powered On

Re: azure blob storage get file content

Hi,

 

I am having EXACTLY the same issue as you today with the GetFileContent function creating an error in IOS or Andoid. I have posted separately on this, but was wondering if you could tell me if you actually resolved the issue without the timer function and if so how.   If not, perhaps you could explain where and how you inserted the timer function (ie when/where/how  did it wait 1 second).

 

In anticipation.

 

Cheers

 

Highlighted
PowerAppUser87
Level: Powered On

Re: azure blob storage get file content

Hi, I have posted both in this chat and in Tim's

 

I am having the same problem. I have a CDS entity that has the Blob Path and a gallery that uses the Azure.GetFileContentUsingPath formula.

 

I have turned off the Explicit Column Selection and Tried Uninstalling and Reinstalling the item.

 

The Formula Used for the Image is:

AzureBlobStorage.GetFileContentByPath(EventGallery.Selected.'Event Floorplan')

 

The Event Floorplan field has this record in it: /pictures/009477a_hb_a_001.jpg

Helpful resources

Announcements
thirdimage

Power Apps Super User Class of 2020

Check it out!

thirdimage

New Badges

Check it out!

thirdimage

Power Apps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

SecondImage

Difinity Conference

The largest Power BI, Power Platform, and Data conference in New Zealand

Top Solution Authors
Top Kudoed Authors
Users online (6,161)