cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
roncam Helper II
Helper II

browser cache issues

hi,

 

i created a custom connector to save signature images to sharepoint and a flow to save the image link in a hyperlink column. Im getting the image back from the sharepoint by referring to the link but after the first save of the image im noticing that the image is updated but when I click the link of the image it is still referring to the previous image until I clear the browser cache.

 

can you help me please ?

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support
Community Support

Re: browser cache issues

Hi @roncam,

Could you please share a screenshot about your flow's configuration?

Do you add a Hyperlink column in your SP list to store the image link within your SP library?

I found that you have posted same issue within your previous thread, please check my response within the following thread:

https://powerusers.microsoft.com/t5/General-Discussion/saving-signature-image-to-sharepoint/m-p/1969...

If you want to clear cache of your browser using Functions in PowerApps, I afraid that there is no way to achieve your needs currently.

I assume that you update your signature image within your app, then your flow would also update the image link within the corresponding Hyperlink column. As an alternative solution, I think the Refresh function could achieve your needs.

You could consider take a try to add a Timer control within your app, then set the Duration property to following:

1000

Set the AutoStart property to following:

true

Set the Repeat property to following:

true

Set the OnTimerEnd property to following:

Refresh('YourSPList')   /* <- Refresh your data source every 1 second */

If you want to hide the Timer control, please set the Visible property of the Timer control to false.

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

1 REPLY 1
Community Support
Community Support

Re: browser cache issues

Hi @roncam,

Could you please share a screenshot about your flow's configuration?

Do you add a Hyperlink column in your SP list to store the image link within your SP library?

I found that you have posted same issue within your previous thread, please check my response within the following thread:

https://powerusers.microsoft.com/t5/General-Discussion/saving-signature-image-to-sharepoint/m-p/1969...

If you want to clear cache of your browser using Functions in PowerApps, I afraid that there is no way to achieve your needs currently.

I assume that you update your signature image within your app, then your flow would also update the image link within the corresponding Hyperlink column. As an alternative solution, I think the Refresh function could achieve your needs.

You could consider take a try to add a Timer control within your app, then set the Duration property to following:

1000

Set the AutoStart property to following:

true

Set the Repeat property to following:

true

Set the OnTimerEnd property to following:

Refresh('YourSPList')   /* <- Refresh your data source every 1 second */

If you want to hide the Timer control, please set the Visible property of the Timer control to false.

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Helpful resources

Announcements
MBAS Gallery 2020

MBAS Gallery 2020

Watch Microsoft Business Applications Summit sessions on-demand.

firstImage

New Ranks and Rank Icons released on April 21!

The time has come: We are finally able to share more details on the brand-new ranks coming to the Power Apps Community!

Top Solution Authors
Top Kudoed Authors
Users online (6,304)