cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
superblueee
Helper I
Helper I

counter +1 based on a sharepoint list

Hello everyone!

I've created a Sharepoint list to update a counter as shown below:

insert photo.JPG
Than i've connected this on Powerapp; second, i've add a button in the browsegallery:
seconda upload.png 
How can I set that if I click on the button above "first slot", the counter incrase by +1?

Thanks!!!

 

23 REPLIES 23
JR-BejeweledOne
Super User
Super User

Ok, are typing [@app] into the formula or is PowerApps displaying it like that?    Don't type that in, just type in App.

 

 Is Titolo the default title field?   hover your mouse right over Titolo or Counter where the darker red lines are.   You might see a different error that will give us some insight into why you are getting this.



If you like this post, give it a Thumbs up. If it answered your question, Mark it as a Solution to enable other users find it.

For both of them Counter and Titolo it says "name is not valid this identifier is not recognized ". So I've tried to change Titolo into title and the darker red line is still there, the title field of the column in the sharepoint list is - Titolo -

Furthermore, there is still a darker line under Counter.
Lastly, I've tried to type only app without [@app], but not works yet.

JR-BejeweledOne
Super User
Super User

Can you add a blank screen and drop a table on it.   Add App as the data source and add the columns so we can see what it's showing for column names?



If you like this post, give it a Thumbs up. If it answered your question, Mark it as a Solution to enable other users find it.

Ok, that's the true table:
superblueee_0-1616099384571.png

 

JR-BejeweledOne
Super User
Super User

Ok try this:   UpdateIf(App; Title = "visite calendario"; {'numero di visite': 'numero di visite' + 1})



If you like this post, give it a Thumbs up. If it answered your question, Mark it as a Solution to enable other users find it.

Ok, now it works; but if I add an - & Navigate('screen1'), it does'nt work

UpdateIf(App; Title = "visite calendario"; {'numero di visite': 'numero di visite' + 1}) & Navigate('screen1')

JR-BejeweledOne
Super User
Super User

You wouldn't use & unless that is the replacement for ;.

 

In US versions ; is what is used to separate commands.    So it would look like this:

 

UpdateIf(App; Title = "visite calendario"; {'numero di visite': 'numero di visite' + 1}); Navigate(Screen1)



If you like this post, give it a Thumbs up. If it answered your question, Mark it as a Solution to enable other users find it.

superblueee_0-1616101875576.png

I've always used "&"... the - ; - says unexpected characters 

JR-BejeweledOne
Super User
Super User

Is Homepage the name of your screen?



If you like this post, give it a Thumbs up. If it answered your question, Mark it as a Solution to enable other users find it.

Yes it's called Homepage; if I use "&" seem it reads the Navigate() as part of the updateif() formula

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Top Solution Authors
Top Kudoed Authors
Users online (75,721)