cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Thanasis
Advocate II
Advocate II

displayMode issue

Hello,

 

I am having an issue and I would really appreciate if anyone can help me with that. 

 

I need a button to be disabled if all requirement are not met. So I have this for displayMode

If(
    
    IsBlank(Rquestion1.Selected.Value) || IsBlank(Rquestion2.Selected.Value) || 
    IsBlank(Rquestion3.Selected.Value) || IsBlank(Rquestion4.Selected.Value) || 
    IsBlank(Rquestion5.Selected.Value) || IsBlank(Rquestion6.Selected.Value) || 
    IsBlank(Rquestion7.Selected.Value) || IsBlank(Rquestion8.Selected.Value) || 
    IsBlank(Rquestion9.Selected.Value) || IsBlank(Rquestion10.Selected.Value) || 
    IsBlank(Rquestion11.Selected.Value)|| IsBlank(Rquestion12.Selected.Value) || 
    IsBlank(Rquestion13.Selected.Value) || IsBlank(SSN1.Text) ||
    (Checkbox1.Value && Checkbox2.Value),
     
     DisplayMode.Edit, 
     DisplayMode.Disabled

It is not working. It only works if I remove the last line : (Checkbox1.Value && Checkbox2.Value),

Thanasis_0-1612794106523.png

Thanasis_1-1612794147414.png

 

Any thoughts ? 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

Since it only the checkbox bit that is not working, can you test it alone because i dont get the result you have:

button.JPG

------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

View solution in original post

4 REPLIES 4
eka24
Super User
Super User

Replace the && with || for the last line:

Checkbox1.Value || Checkbox2.Value

 

If you meant Unchecked for both checkboxes then:

!Checkbox1.Value || !Checkbox2.Value

------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Hello 

 

If I don't put the checkboxes in the formula is working great the submit button is disabled if any of the question is not answered. Once I put the checkboxes in it does not work. It's like it screws up the whole formula. Once I add this !Checkbox1.Value || !Checkbox2.Value, or Checkbox1.Value || Checkbox2.Value, or (Checkbox1.Value && Checkbox2.Value), the submit button get enabled even if none of the questions are answered. 111111111111111.png


Any thoughts ?

Since it only the checkbox bit that is not working, can you test it alone because i dont get the result you have:

button.JPG

------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

View solution in original post

You where right @eka24 , it was a user error on my side. Thank you for all of  your help. 

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (1,291)