cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Simon_P
Level: Power Up

getPastTime(1, 'Month') returning wrong month

I have a monthly flow that adds a row into an enitity for all users. the formula i use is: getPastTime(1, 'Month')

 

This formula doesn't return September though. I created a seperate flow that use emails me the details

 

The result of the mail is:

-1 = August 2019
Formula = formatDateTime(getPastTime(1, 'Month'), 'MMMM yyyy')
-2 = August 2019
Formula = formatDateTime(getPastTime(2, 'Month'), 'MMMM yyyy')
-3 = July 2019
Formula = formatDateTime(getPastTime(3, 'Month'), 'MMMM yyyy')
-4 = June 2019
Formula = formatDateTime(getPastTime(4, 'Month'), 'MMMM yyyy')

 

I can't see what i am doing wrong here.

3 REPLIES 3
npalmer610
Level: Powered On

Re: getPastTime(1, 'Month') returning wrong month

I'm having the same issue. Hope someone can get back about this. The expression I'm using is 

getPastTime(1, 'Month', 'MMMM') and that returns August 2019 instead of September 2019.

Community Support Team
Community Support Team

Re: getPastTime(1, 'Month') returning wrong month

Hi @Simon_P ,

Based on the issue that you mentioned, I have made a test on my side, and don't have the issue that you mentioned. The screenshot as below:1.JPG

The result as below:2.JPG

set the Inputs field of the "Compose" action to following:

getPastTime(1,'Month','MMMM yyyy')

set the Inputs field of the "Compose 2" action to following:

subtractFromTime(utcNow(),1,'Month','MMMM yyyy')

Note: It is not necessary to add additional formatDateTime() function to convert the date time value.

On your side, please consider take a try with above subtractFromTime(...) formula, then check if the issue is solved.

 

If the issue still exists, please consider take a try with the following formula within your flow's action:

addDays(utcNow(),-31, 'MMMM yyyy')

then check if the issue is fixed.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Simon_P
Level: Power Up

Re: getPastTime(1, 'Month') returning wrong month

Morning @v-xida-msft,

 

I've not been able to test this properly yet, as when i use the erroring formula, it is returning the correct data today (2nd Oct). I will need to test again on the 1st.

 

When it comes to adding the date into an Entity as a date, the formula you gave doesn't work, as it throws the below error:

"message": "DateTime is less than minumum value supported by CrmDateTime. Actual value: 01/01/0001 00:00:00, Minimum value supported: 01/01/1753 00:00:00",

 

What should i be using to get last month as a date (for entry to an entity)

 

Helpful resources

Announcements
thirdimage

Power Apps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

SecondImage

Difinity Conference

The largest Power BI, Power Platform, and Data conference in New Zealand

Top Kudoed Authors (Last 30 Days)
Users online (5,333)