cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Advocate II
Advocate II

iPad app not loading with ver 3.18061.12

Older versions of application open on iPad fine.  Since version 3.18061.12, powerapps loads fine, but the actual application I am building just hangs at the "opening" screen

27 REPLIES 27
Frequent Visitor

So after looking at other threads about apps not loading i deleted powerapps and reinstalled it.(i tried this when it first happed also)

Currently the app i had for testing works on iPad2 with version 3.18071.33 and .36 

It did not work before reinstalling powerapps yesterday.

Also apps on older versions still do not work and crash even if i republish them after crashing, however if i publish an app to the current version then load it for the first time since reinstalling, it works. 

Session ID: 1ef16c37-89b1-4334-9cd2-f2c409fcbce2 when it worked.

Session ID: 2b1efc5c-8ebb-4863-a9b0-fe2d3dfde092 when it crashed.

I just looked at your session that crashed and what is happening is that the app is crashing because of some syntax error in the executing code. This issue has been fixed and to make sure you don't get it, you would need to do two things: 

- Download latest version of PowerApps from the app store. 

- Republished your app. 

 

if you do both and its still failing, let me know and I will look again. Feel free to use email if you want: faisalil at microsoft dot com 

View solution in original post

Hurray!  Success!

 

Thank you all for your hard work!

Frequent Visitor

It works, thanks for this!

I had the same issue on both an iPad and Android device when trying to load any of my downloaded applications to use in offline mode (this only seemed to be a problem with applications with a data connection).  The applications loaded fine if I am online but if I am offline my applications would simply hang in the 'Opening' blue screen.  It would be nice to be able to debug this problem but I am not aware of any debug mode or error log. 

 

The problem went away, probably after I made some changes to how I was calling the data connections.  Sometimes there are errors that appear within the apps. but I don't know the error 'level' of these messages so I'm assuming only errors of a certain level are displayed in the app.

Microsoft
Microsoft

Can you send me a session Id and email me at faisalil at Microsoft dot com? I want to get more info. What is happening with you is definitely a bug. Apps should continue to open when the user is offline.

Hello @willick

 

I had an issue with my apps being stuck at "Opening" a while back. Here is how I solved it: 

 

  • Uninstall Microsoft Authenticator app from the mobile device
  • Uninstall the PowerApps app from the mobile device
  • Reinstall Authenticator app
  • Reinstall PowerApps app

After that, the user was able to get past the "Opening" message for all apps and has not had an issue since. 

 

Hope this helps. 

Hello,

Just a heads up, had to do this again today (4 months after initial reporting). App was stuck at "Opening". Had to uninstall and reinstall PowerApp App on iPhone.

Helpful resources

Announcements
secondImage

Experience what’s next for Power Apps

Join us for an in-depth look at the new Power Apps features and capabilities at the free Microsoft Business Applications Launch Event.

Power Apps Community Call

Power Apps Community Call: February

Did you miss the call? Check out the Power Apps Community Call here.

New Power Super Users

Congratulations!

We are excited to announce the Power Apps Super Users!

New Badges

New Solution Badges!

Check out our new profile badges recognizing authored solutions!

Top Kudoed Authors
Users online (26,131)