cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper I
Helper I

identifier is not recognized in one version - Works in another version, but not in current version

Hi,

 

I'm currently rebuilding an app of mine, and while copying some of the old code into the new app, for some strange reason the code doesn't work.

 

See screenshots below.

I'm trying to populate a dropdowns defaultselecteditems which worked perfectly fine in the old app, but now in the new app it's acting up.

 

New version of app made in Powerapps version: 3.20021.27 that doesn't work.

sLb4PKl

Old version of app made in Powerapps version: 3.20014.23 that does work.

7yWp6K0

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Helper I
Helper I

Re: identifier is not recognized in one version - Works in another version, but not in current version

Hi Phoebe Liu,

I found out what caused the error, it wasn't getting the correct data source. 🙂image.png

 

Thanks for the help anyways, much appreciated! 

View solution in original post

2 REPLIES 2
Highlighted
Community Support
Community Support

Re: identifier is not recognized in one version - Works in another version, but not in current version

Hi @JakobDahl ,

Could you tell me

1)the data type of Distributionslister field?

     is this field's structure like this:  {Id:.....,Value:....} and a lookup field?

2)what does the formula use for?

I assume that:

The Distributionslister field is a lookup field, and you want to get a table with two columns :Id and Value from the filtered items' look up field.

I've tested your formula and I think you need a little change.

Try this formula:

Filter(ForAll(OB_Roller_ComboBox.SelectedItems.Value,LookUp(Roller,Value=Title,Distributionslister)),
!IsBlank(Value))

Then you could already get the nested table's value, no need to use two ForAll functions and Ungroup function.

 

About why the formula works in your previous version, PowerApps is updating all the time. The formulas that you use may be out of time.

 

 

Best regards,

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Helper I
Helper I

Re: identifier is not recognized in one version - Works in another version, but not in current version

Hi Phoebe Liu,

I found out what caused the error, it wasn't getting the correct data source. 🙂image.png

 

Thanks for the help anyways, much appreciated! 

View solution in original post

Helpful resources

Announcements
secondImage

Demo-Extravaganza 2020

Check out these cool Power Apps & vote on your favorite!

secondImage

Robotic Process Automation

Let's talk about the solution provided by Microsoft for Robotic Process Automation (RPA)

secondImage

Community Highlights

Check out whats happening in Power Apps

secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

Top Solution Authors
Top Kudoed Authors
Users online (9,926)