cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

my app no longer renders in release 3.19054.15

i reverted back to 3.19053.21 and everything is working fine now.

 

my app no longer renders in release 3.19054.15, on load the homepage is broken.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Power Apps
Power Apps

Re: my app no longer renders in release 3.19054.15

@hermtro @aorphan @RiannG We have identified that a bug was shipped in 3.19054 that affects a subset of apps that make use of components and/or enhanced group controls.  This week's release, 3.19061, contains a fix for the bug and is currently being deployed worldwide--it will complete by end-of-day tomorrow.  

 

For immediate mitigation, I would advise using the previous version of Studio (https://create.powerapps.com/v3.19053.21.115177711/studio/) to edit and publish the app. If the app won’t open, it will have to first be restored to a previous version that is 3.19053.x or less from the Versions tab in PowerApps portal (https://make.powerapps.com).

View solution in original post

11 REPLIES 11
Highlighted
Dual Super User
Dual Super User

Re: my app no longer renders in release 3.19054.15

That would suggest that something you are doing on the home page is now broken by tightening things up in the newer version.  Can you load it in the designer? What controls/formulas are on the page?



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.
Highlighted
Frequent Visitor

Re: my app no longer renders in release 3.19054.15

Loads fine in the designer.

Screen has an html box, 4 buttons, 2 symbols, few labels and a display form.

Form data is loaded from an Azure SQL view.
Highlighted
Community Support
Community Support

Re: my app no longer renders in release 3.19054.15

Hi @hermtro 

 

Could you please try to test with other broewers?

Could you please consider turn off the "Improved app rendering (final validation)" option within Advanced settings of App settings of your app, then re-publish your app, check if the issue is solved. 

 

Hope this could be helpful.

 

Best Regards.

Yumia

 

 

 

Highlighted
Power Apps
Power Apps

Re: my app no longer renders in release 3.19054.15

@hermtro Are you able to provide a session ID for an affected session? Or at least an app ID? 

Highlighted
Frequent Visitor

Re: my app no longer renders in release 3.19054.15

Hi Corey, 

 

Not sure where to find a session ID, however the App ID is 91907b12-fa82-41ae-a94e-0e356334d815.

 

This is the timeline of my issues, as you can see, I reverted back later on that night and every works fine now on 3.19.053.21.

 

Hope this helps

 

Annotation 2019-06-10 084437.jpg

Highlighted
Frequent Visitor

Re: my app no longer renders in release 3.19054.15

thanks for the suggestions,

 

I have tested on an Android phone, edge and chrome, issue is consistent.

 

I am unable to disable "Improved app rendering (final validation)" feature because of several Groups that I have created. However if the groups are potentially causing issues, I might be able to find a way of doing this differently. 

 

I am mostly using groups in lieu of components, because I had a component issue a little while ago and had to backout of components all together.

 

/troy

Highlighted
Advocate II
Advocate II

Re: my app no longer renders in release 3.19054.15

I'm also having the same issues with 3.19054.15. Multiple apps, same behaviors in IE, Chrome, Firefox. OnStart actions and also OnVisible actions for additional screens (for apps that will still load past OnStart) aren't working properly, but context variables and also I believe relative sizing isn't working. Revering to 3.19053.21 resolves the issues, as well as turning off improved rendering (which is absolutely not practical for apps with large amounts of groups).

Highlighted
Resolver I
Resolver I

Re: my app no longer renders in release 3.19054.15

We are also having this issue. App functions and renders properly in edit mode, but once we publish use it in play mode, only screens 1 and 2 render properly. All of our other screens do not render properly. This bug was introduced recently and is affecting all our apps. What changed?

Highlighted
Power Apps
Power Apps

Re: my app no longer renders in release 3.19054.15

@hermtro @aorphan @RiannG We have identified that a bug was shipped in 3.19054 that affects a subset of apps that make use of components and/or enhanced group controls.  This week's release, 3.19061, contains a fix for the bug and is currently being deployed worldwide--it will complete by end-of-day tomorrow.  

 

For immediate mitigation, I would advise using the previous version of Studio (https://create.powerapps.com/v3.19053.21.115177711/studio/) to edit and publish the app. If the app won’t open, it will have to first be restored to a previous version that is 3.19053.x or less from the Versions tab in PowerApps portal (https://make.powerapps.com).

View solution in original post

Helpful resources

Announcements
secondImage

Demo-Extravaganza 2020

Check out these cool Power Apps & vote on your favorite!

secondImage

Robotic Process Automation

Let's talk about the solution provided by Microsoft for Robotic Process Automation (RPA)

secondImage

Community Highlights

Check out whats happening in Power Apps

secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (11,397)