cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

new list records not showing in gallery

Hi,

 

I created a powerapp from an existing sharepoint list. The record list displays all existing records but the new records added through the powerapp does not shows in a Browser screen. The record get saved in the Sharepoint list. Refresh button works for updates fine. I can see updated records, but not new.

If I create new powerapp from the same sharepoint list (with new records), all records shows in Browser screen.

16 REPLIES 16
Highlighted

With "," after in State, it is does not work at all.

 

JuliaM_1-1593618726770.png

 

 

 

Highlighted
Continued Contributor
Continued Contributor

I've had a similar issue like this before. Do the new records show up once you have left the browse screen and come back? 

If this solved the problem for you, feel free to hit "Accept as Solution" so others can find the answer easier. 🙂

Kind regards,

Ben Fetters
Power Apps/Power Automate Developer
www.sovereignsp.com
Highlighted

No. It is shown on the list, but not in an application. Updated records are OK.

Highlighted
Continued Contributor
Continued Contributor

Hum...I'm sorry that is happening! What you could possibly try, just to rule out some possibilities and help narrow down the problem could be creating a new app with a gallery pointing at the same list and a form that creates new items etc. to see if that works or still doesn't work. Hopefully that can help bring some answers and narrow it down perhaps.

 

Let me know if that helps at all or not!

If this solved the problem for you, feel free to hit "Accept as Solution" so others can find the answer easier. 🙂

Kind regards,

Ben Fetters
Power Apps/Power Automate Developer
www.sovereignsp.com
Highlighted

I'll try today and everybody know. Thanks you so much.

Highlighted

Hi @JuliaM ,

 

Filter syntax is 

FilterTableFormula1 [, Formula2, ... ] )

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/functions/function-filter-lookup#syntax
Examples:
https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/functions/function-filter-lookup#exampl...

 

Having said that "," will not work as it is not the right syntax.

 

I hope this resolved your issue if you see any challenge/need further help please let me know I am always happy to do it for my community.

Regards,
Krishna
If this post helps you give a 👍 and if it solved your issue consider Accept it as the solution to help the other members find it more.


I hope this resolved your issue if you see any challenge/need further help please let me know I am always happy to do it for my community.

Proud to be a Super User!

Regards,
KrishnaV
Business Applications MVP
Twitter | Linkedin | YouTube | GitHub
If this post helps you give a 👍 and if it solved your issue consider Accept it as the solution to help the other members / new members of the community.
Highlighted
Frequent Visitor

Wanted to let anyone else having this problem know what I did; it is the filter function causing a problem. I created 2 galleries with one's formula for Items as the following:

 

SortByColumns(
    Search(
        [@'[dbo].[Support_Contacts]'],
        TextSearchBox1.Text,
        "Site_Name",
        "Service_Type",
        "Service_Provider",
        "Contact_Name"
    ),
    "Contact_Type",
    If(
        SortDescending1,
        Descending,
        Ascending
    )
)

 

However, this search function does not work for me because I am looking at splitting all phrases in my search box to search across multiple columns; like a google query.

 

But doing this formula above, I can see my newly added records (that I can see on my backend side). 

 

My problem is that I couldn't see it with this formula that I use for search on split keywords across multiple columns:

 

SortByColumns(
    Filter(
        '[dbo].[Support_Contacts]',
            Find(
                "0",
                Concat(
                    Filter(
                        Split(
                            TextSearchBox1.Text,
                            " "//or any delimiter.
                        ),
                        !IsBlank(Result)
                    ),
                    If(
                        TrimEnds(Result) in Contact_Name || TrimEnds(Result) in Site_Name || TrimEnds(Result) in Business_Unit || TrimEnds(Result) in Service_Type || TrimEnds(Result) in Contact_Type || TrimEnds(Result) in Service_Provider || TrimEnds(Result) in Contact_Email || TrimEnds(Result) in Contact_Phone,// etc.
                        "1",
                        "0"
                    )
                )
            )
    ),
    "Contact_Type",
    If(
        SortDescending1,
        Descending,
        Ascending
    )
)

 And then I read up on delegation with large (over 500 items, which is the case in my situation).

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/delegation-overview

 

For me,  I don't expect my data source to be over 2000 records, but it is > 500. 

Changing the setting to 2000 (the max) worked for me; and I could keep my 2nd formula. It's messy, but shows the limitations of this platform. 

 

 

 

 

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (8,676)