cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Delid4ve
Impactful Individual
Impactful Individual

[object Object] - JSON

Creating a collection from an SQL stored procedure using flow.

Fields that are of type decimal are not being processed correctly by powerapps.

In the flow response payload they are set as type: string and looking at the output results they are displayed correctly in the JSON repsonse.

Within powerapps:

In any form / data table / text box the field is represented by [object Object] and when viewing the collection from the menu it shows as blank.

As soon as the populated field is selected it crashes powerapps (in browser).

 

Is this a bug or am i missing something here?

I have tried to put into a new collection to see if the issue was with the current collection however it makes no difference.

1 ACCEPTED SOLUTION

Accepted Solutions
Delid4ve
Impactful Individual
Impactful Individual

All other fields populated correctly.

I have tested:

Removed and readded flow - didnt fix

Changed json to type:number - didnt fix

 

I have, as a workaround, cast my decimal to nvarchar(max) in my stored procedure and changed the type to string.

This works ok but there does seem to be some form of bug there for decimals

 

View solution in original post

2 REPLIES 2
v-xida-msft
Community Support
Community Support

Hi @Delid4ve ,

Do you want to return a table value from your flow back to your app?

 

Based on the issue that you mentioned, I have made a test on my side, and don't have the issue that you mentioned. Within your app, please check if the collection populated with proper records returned from your flow.

 

More details about returning table value from a flow back to an app, please check my response within the following thread:

https://powerusers.microsoft.com/t5/Building-Power-Apps-Formerly/How-to-display-the-result-of-SQL-Se...

https://powerusers.microsoft.com/t5/Building-Power-Apps-Formerly/Read-Excel-Stored-in-SharePoint/m-p...

 

Please also check and see if the following blog and video could help in your scenario:

https://powerapps.microsoft.com/en-us/blog/return-an-array-from-flow-to-powerapps-response-method/

https://www.youtube.com/watch?v=K_H5r0nzwy4

 

Please make sure you have specified proper JSON Schame value within the "Response Body JSON scema" field of the "Response" action in your flow.

Note: The JSON Schema value is based on the result the "Execute stored procedure" action returned in your flow.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Delid4ve
Impactful Individual
Impactful Individual

All other fields populated correctly.

I have tested:

Removed and readded flow - didnt fix

Changed json to type:number - didnt fix

 

I have, as a workaround, cast my decimal to nvarchar(max) in my stored procedure and changed the type to string.

This works ok but there does seem to be some form of bug there for decimals

 

View solution in original post

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Power Apps June 2021

June Power Apps Community Call

Don't miss the call this month on June 16th - 8a PDT

Top Solution Authors
Top Kudoed Authors
Users online (93,102)