cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper III
Helper III

"An error occurred on the server. Server Response: Not a valid Connector Error Response" Cannot Connect to azure

Trying to connect to azure database. Can connect, but I cannot run a simple query. My entire app will not work. Everything worked fine yesterday and no changes were made. 

13 REPLIES 13
Highlighted
Super User
Super User

Re: "An error occurred on the server. Server Response: Not a valid Connector Error Response" Cannot Connect to azure

Hello @Rebeccak 

 

Are you perhaps using a firewall on the SQL Azure db?

 

If you say that you can connect, is this through SQL Studio or PowerApps or Flow that you can connect, and were are you getting the error from?

 

If you are talking about a simply query, I assume you are referring to Flow? If so, when you run the Flow please make sure that you have the correct connection selected. If you run a flow on demand, you have to specify the correct connection (table or view) even thought it has been specified in the Flow action as well. See attached.

SQL Connection Run Flow - Error on Server - Bad GatewaySQL Connection Run Flow - Error on Server - Bad Gateway

 

Let me know if you don't come right.

 

Dawid van Heerden
Follow on Twitter: @davestechtips
Subscribe to YouTube: https://www.youtube.com/davestechtips?sub_confirmation=1
**If you found this reply helpful, please mark this as the answer to close the topic and make it easier to find for other people with similar questions. AND we get points for it 😉

Highlighted
Helper III
Helper III

Re: "An error occurred on the server. Server Response: Not a valid Connector Error Response" Cannot Connect to azure

I created a seperate app in powerapps. Inserted a gallery. Connected that gallery to the same Azure sql database table that im using in my "Main" app. The Data shows.  If i put a Filter(database,Field1 ="Status") ......or anything simple like that,  it fails.  I cannot make collections or anything in the test app.  I am not running flows. Just simple fill of a gallery.  My main app is very complex.  I have not made any changes since yesterday.  It was running great.  Today, i have nothing. 

Highlighted
Super User
Super User

Re: "An error occurred on the server. Server Response: Not a valid Connector Error Response" Cannot Connect to azure

Is the main app also not able to filter anything in the database?

Highlighted
Helper III
Helper III

Re: "An error occurred on the server. Server Response: Not a valid Connector Error Response" Cannot Connect to azure

Yes, I created the test app, because the main app is providing no data. 

Highlighted
Helper III
Helper III

Re: "An error occurred on the server. Server Response: Not a valid Connector Error Response" Cannot Connect to azure

I think i have narrowed down the issue.  This is the filter I use. Filter('[dbo].[testDB]',DeployedDate >=Date(Year(Now()),01,01))

 

This throws an error. So I tried just doing Today()  didn't work. Tried just filtering on different fields, and it worked. Tried <>  with the date fields and it worked. Tried = with the date fields and it worked. So it looks like the error is being thrown from the >=  or <=  which I use everywhere in the app.  What change was made to make that not work properly now, when it worked fine yesterday?

Highlighted
Community Support
Community Support

Re: "An error occurred on the server. Server Response: Not a valid Connector Error Response" Cannot Connect to azure

Hi @Rebeccak ,

That's a little strange.

Maybe try this formula:

Filter('[dbo].[testDB]',(DeployedDate >Date(Year(Now()),01,01))||
                                  (DeployedDate =Date(Year(Now()),01,01))
         )

 

Best regards,

Community Support Team _ Phoebe Liu

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Helper III
Helper III

Re: "An error occurred on the server. Server Response: Not a valid Connector Error Response" Cannot Connect to azure

the > function does not work either only = and <>

Highlighted
Super User
Super User

Re: "An error occurred on the server. Server Response: Not a valid Connector Error Response" Cannot Connect to azure

Hi @Rebeccak 

 

What is the datatype that you are using in SQL?

Highlighted
Helper III
Helper III

Re: "An error occurred on the server. Server Response: Not a valid Connector Error Response" Cannot Connect to azure

I am using a sql connector to an azure database. The field is a date field.  I only want to filter data in the date field. This worked fine for months before the new release, I have changed nothing. 

Filter('[dbo].[testdb]',DeployedDate >= Date(Year(Now()),01,01))

Helpful resources

Announcements
secondImage

Demo-Extravaganza 2020

Check out these cool Power Apps & vote on your favorite!

secondImage

Robotic Process Automation

Let's talk about the solution provided by Microsoft for Robotic Process Automation (RPA)

secondImage

Community Highlights

Check out whats happening in Power Apps

secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

Top Solution Authors
Top Kudoed Authors
Users online (8,246)