cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
larivibi Advocate II
Advocate II

"Register error" for a FLOW asking for an Array value in PowerApps

From PowerApps, I create a Flow from a button (OnSelect).
In that Flow the only command I do is "Initialise a variable" of type Array.
Then, in the Value field of "Initialise a variable", I put "Ask in PowerApps". So far so good.
Now, when I try to connect my flow to the button (by going to the menu bar of PowerApps / Actions / Flows / Then select the new flow I just created, I get a "Register Error".
I have tried a dozen times. Every time the same result.

However, Is I do the same thing, but Initialising a String or Object variable, Everything works flawlessly.
Anybody else has the same issue ?

Any workaround for this ?
8 REPLIES 8
ltabosa
Regular Visitor

Re: "Register error" for a FLOW asking for an Array value in PowerApps

I had the same problem with Array variable. Did you find the answer?

Anonymous
Not applicable

Re: "Register error" for a FLOW asking for an Array value in PowerApps

I have the same problem.

Highlighted
zac1 Advocate II
Advocate II

Re: "Register error" for a FLOW asking for an Array value in PowerApps

Same issue here, no one have a work around?

AdrianMitroiu Helper I
Helper I

Re: "Register error" for a FLOW asking for an Array value in PowerApps

Same here. No answers yet ?

larivibi Advocate II
Advocate II

Re: "Register error" for a FLOW asking for an Array value in PowerApps

No answers yet.

I went the long way, concatenating the array, then re-splitting it when necessary...

TopShelf-MSFT Community Champion
Community Champion

Re: "Register error" for a FLOW asking for an Array value in PowerApps

Hi All,

 

I have found a "solved" post that may help. Please review the detailed response from our Customer Support Team in the following thread:

 

https://powerusers.microsoft.com/t5/General-Discussion/Registering-error-when-trying-to-add-a-Flow-t...

 

@TopShelf-MSFT

larivibi Advocate II
Advocate II

Re: "Register error" for a FLOW asking for an Array value in PowerApps

The answer pretty much sums up what I responded earlier. Only the String variable works at the moment.
So by passing a string and splitting it later works. But creating an array variable doesn't work yet.
Super User
Super User

Re: "Register error" for a FLOW asking for an Array value in PowerApps

Any update on this? Is it still not possible to create an array from PowerApps trigger? 

Is it on a backlog somewhere or will it never happen? There are a LOT of people facing this issue.

Helpful resources

Announcements
MBAS Gallery 2020

MBAS Gallery 2020

Watch Microsoft Business Applications Summit sessions on-demand.

firstImage

New Ranks and Rank Icons released on April 21!

The time has come: We are finally able to share more details on the brand-new ranks coming to the Power Apps Community!

Top Solution Authors
Top Kudoed Authors
Users online (6,751)