cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate II
Advocate II

"Register error" for a FLOW asking for an Array value in PowerApps

From PowerApps, I create a Flow from a button (OnSelect).
In that Flow the only command I do is "Initialise a variable" of type Array.
Then, in the Value field of "Initialise a variable", I put "Ask in PowerApps". So far so good.
Now, when I try to connect my flow to the button (by going to the menu bar of PowerApps / Actions / Flows / Then select the new flow I just created, I get a "Register Error".
I have tried a dozen times. Every time the same result.

However, Is I do the same thing, but Initialising a String or Object variable, Everything works flawlessly.
Anybody else has the same issue ?

Any workaround for this ?
8 REPLIES 8
Highlighted
Regular Visitor

Re: "Register error" for a FLOW asking for an Array value in PowerApps

I had the same problem with Array variable. Did you find the answer?

Highlighted
Anonymous
Not applicable

Re: "Register error" for a FLOW asking for an Array value in PowerApps

I have the same problem.

Highlighted
Advocate II
Advocate II

Re: "Register error" for a FLOW asking for an Array value in PowerApps

Same issue here, no one have a work around?

Highlighted
Helper I
Helper I

Re: "Register error" for a FLOW asking for an Array value in PowerApps

Same here. No answers yet ?

Highlighted
Advocate II
Advocate II

Re: "Register error" for a FLOW asking for an Array value in PowerApps

No answers yet.

I went the long way, concatenating the array, then re-splitting it when necessary...

Highlighted
Anonymous
Not applicable

Re: "Register error" for a FLOW asking for an Array value in PowerApps

Hi All,

 

I have found a "solved" post that may help. Please review the detailed response from our Customer Support Team in the following thread:

 

https://powerusers.microsoft.com/t5/General-Discussion/Registering-error-when-trying-to-add-a-Flow-t...

 

@Anonymous

Highlighted
Advocate II
Advocate II

Re: "Register error" for a FLOW asking for an Array value in PowerApps

The answer pretty much sums up what I responded earlier. Only the String variable works at the moment.
So by passing a string and splitting it later works. But creating an array variable doesn't work yet.
Highlighted
Super User
Super User

Re: "Register error" for a FLOW asking for an Array value in PowerApps

Any update on this? Is it still not possible to create an array from PowerApps trigger? 

Is it on a backlog somewhere or will it never happen? There are a LOT of people facing this issue.

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Come join us today! Find your favorite faces from the community presenting at the Power Platform Community Conference!

Watch Now

Experience what’s next for Power Apps

See the latest Power Apps innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (3,080)