cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
larivibi
Level: Powered On

"Register error" for a FLOW asking for an Array value in PowerApps

From PowerApps, I create a Flow from a button (OnSelect).
In that Flow the only command I do is "Initialise a variable" of type Array.
Then, in the Value field of "Initialise a variable", I put "Ask in PowerApps". So far so good.
Now, when I try to connect my flow to the button (by going to the menu bar of PowerApps / Actions / Flows / Then select the new flow I just created, I get a "Register Error".
I have tried a dozen times. Every time the same result.

However, Is I do the same thing, but Initialising a String or Object variable, Everything works flawlessly.
Anybody else has the same issue ?

Any workaround for this ?
8 REPLIES 8
ltabosa
Level: Powered On

Re: "Register error" for a FLOW asking for an Array value in PowerApps

I had the same problem with Array variable. Did you find the answer?

Anonymous
Not applicable

Re: "Register error" for a FLOW asking for an Array value in PowerApps

I have the same problem.

zac1
Level: Powered On

Re: "Register error" for a FLOW asking for an Array value in PowerApps

Same issue here, no one have a work around?

AdrianMitroiu
Level: Powered On

Re: "Register error" for a FLOW asking for an Array value in PowerApps

Same here. No answers yet ?

larivibi
Level: Powered On

Re: "Register error" for a FLOW asking for an Array value in PowerApps

No answers yet.

I went the long way, concatenating the array, then re-splitting it when necessary...

TopShelf-MSFT
Level 10

Re: "Register error" for a FLOW asking for an Array value in PowerApps

Hi All,

 

I have found a "solved" post that may help. Please review the detailed response from our Customer Support Team in the following thread:

 

https://powerusers.microsoft.com/t5/General-Discussion/Registering-error-when-trying-to-add-a-Flow-t...

 

@TopShelf-MSFT

larivibi
Level: Powered On

Re: "Register error" for a FLOW asking for an Array value in PowerApps

The answer pretty much sums up what I responded earlier. Only the String variable works at the moment.
So by passing a string and splitting it later works. But creating an array variable doesn't work yet.
Super User
Super User

Re: "Register error" for a FLOW asking for an Array value in PowerApps

Any update on this? Is it still not possible to create an array from PowerApps trigger? 

Is it on a backlog somewhere or will it never happen? There are a LOT of people facing this issue.

Helpful resources

Announcements
New Ranks and Rank Icons in April

'New Ranks and Rank Icons in April

Read the announcement for more information!

Better Together’ Contest Finalists Announced!

'Better Together’ Contest Finalists Announced!

Congrats to the finalists of our ‘Better Together’-themed T-shirt design contest! Click for the top entries.

thirdimage

Power Apps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Join THE global Microsoft Power Platform event series

Attend for two days of expert-led learning and innovation on topics like AI and Analytics, powered by Dynamic Communities

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

thirdimage

Community Summit North America

Innovate, Collaborate, Grow - The top training and networking event across the globe for Microsoft Business Applications

Top Solution Authors
Top Kudoed Authors
Users online (9,561)