cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

"the request was not sent or there was no response from the server" issue in offline mode

Hi guys,

 

So im trying to figure out the errors i am getting in my app when i start it in offline mode: The request was not sent or there was no response from the server. Check your internet connection. Server response:"Entity name" failed: Null". Onstart i get a bunch of errors and im not really sure what the problem is. I tried looking for an answer on the forums but no succes yet. Im aware my code probably won't be spot on but the app runs fine online and offline. 


I also get the same errors when i go through the screens in the app in offline mode. But maybe if i understand the on start problems i can solve the rest as well. For patching i use If(connection.connected, patch, collect locally;savedata)

 

My "on start" code:

 

LoadData(
    matlist,
    "savedMatlist",
    true
);
If(
    Connection.Connected,
   // make collection to store offline data verplaatsing
    ClearCollect(
        verplaatsingList,
        verplaatsing
    );
    Clear(verplaatsingList);
    //make collection to store offline data tijdgewerkt
ClearCollect(
        tijdGewerktList,
        tijdGewerkt
    );
    Clear(tijdGewerktList);
    //make collection to store offline data comments
ClearCollect(
        commentsList,
        commentsEnSignature
    );
    Clear(commentsList);
Concurrent(
        ClearCollect(
            gebruikersCol,
            gebruikers
        ),
        ClearCollect(
            materiaalCol,
            materiaal
        ),
        ClearCollect(
            werkBonCol,
            werkBon
        ),
        ClearCollect(
            werkBonLijstCol,
            werkBonLijst
        ),
        ClearCollect(
            materiaalGebruiktCol,
            materiaalGebruikt
        ),
        ClearCollect(
            verplaatsingCol,
            verplaatsing
        ),
        ClearCollect(
            commentsEnSignatureCol,
            commentsEnSignature
        )
    );
    //proberen
    Clear(materiaalCol);
//loaddata local offline data verplaatsinglist
    LoadData(
        verplaatsingList,
        "savedverplaatsingCol1",
        true
    );
//loaddata local offline data tijdgewerktlist
    LoadData(
        tijdGewerktList,
        "savedTijdGewerktList",
        true
    );
//loaddata local offline data commentslist
    LoadData(
        commentsList,
        "savedCommentsList",
        true
    );
//loaddata local offline data materiaalcol
    LoadData(
        materiaalCol,
        "savedMateriaalCol",
        true
    );

    SaveData(
        gebruikersCol,
        "savedGebruikers"
    );
    SaveData(
        werkBonCol,
        "savedWerkbon"
    );
    SaveData(
        werkBonLijstCol,
        "savedWerkbonLijst"
    );
    SaveData(
        materiaalCol,
        "savedMateriaalCol"
    );
    SaveData(
        materiaalGebruiktCol,
        "savedMateriaalGebruiktCol"
    );
    SaveData(
        verplaatsingCol,
        "savedverplaatsingCol"
    );
    SaveData(
        commentsEnSignatureCol,
        "savedcommentsEnSignatureCol"
    )
//if offline load all the data
    ,
    LoadData(
        gebruikersCol,
        "savedGebruikers",
        true
    );
    LoadData(
        werkBonCol,
        "savedWerkbon",
        true
    );
    LoadData(
        werkBonLijstCol,
        "savedWerkbonLijst",
        true
    );
    LoadData(
        materiaalCol,
        "savedMateriaalCol",
        true
    );
    LoadData(
        materiaalGebruiktCol,
        "savedMateriaalGebruiktCol",
        true
    );
    LoadData(
        verplaatsingCol,
        "savedverplaatsingCol",
        true
    );
    LoadData(
        commentsEnSignatureCol,
        "savedcommentsEnSignatureCol",
        true
    )
)

 

  

What am i doing wrong?


Kind regards,


Anthony

4 REPLIES 4
Anonymous
Not applicable

Anyone who can help me with this issue?

v-albai-msft
Community Support
Community Support

Hi @Anonymous,

Where is your Patch function?

From your formula, I have found the following two situations that may be causing your problem:

1. See below picture, when has connection, you create a collection called “verplaatsingList”, and then clear this collection, so this collection is empty now:

v-albai-msft_0-1616571660506.png

But then, with the same condition(has connection), you load data into this collection:

v-albai-msft_1-1616571660508.png

So, I would suggest you directly use below formula for above situation:

//Create an empty collection
  ClearCollect(
        verplaatsingList,
        “”
    );
//loaddata local offline data verplaatsinglist
    LoadData(
        verplaatsingList,
        "savedverplaatsingCol1",
        true
);

2. No matter you have or do not have connection, you should first load your data, instead of only load data when it has no connection. So the right order should like below:

LoadData(gebruikersCol,"savedGebruikers",true);
If(Connection.Connected,
ForAll(gebruikersCol,
Patch());
Clear(TempCollection);SaveData(gebruikersCol," savedGebruikers ")
)

If above still do not work, I will suggest you try this---For test purpose, use only for example two collections/datafile to test if your formula is right(remove all other collections). Refine your formula, and if two collections can work, add all the other collections to the formula.

You can refer to this video by Shane Young for more information about PowerApps offline mode:

PowerApps Offline Mode - YouTube

Best regards,

Allen

Anonymous
Not applicable

hi @v-albai-msft 

 

The way i tried my app to work is,

1. the users can add items in a local collection when in offline mode

2. when connection is back a button appears to patch this local collections, empty them and saving them again.

3. when users have added items in a offline collection and they restart the app the items are still there untill they use the button to patch.

I think my mistake is that some "offline collections" have the same name as the "online collections" like: materiaalcol, werkboncol, werkbonlijstcol, materiaalgebruiktcol, commentsensignaturecol. 

 

2. Because they have the same collection names thats also the reason why i cant first load all the data and after that replace that data with the sharepoint list data. That way i can't really :

 

loaddata(localcollection)
if(connection.connected,
   collect all sharepoint list into collections
  )
if(offline,
  collect all local collections
  )

 

 

My patch function for all local collections looks like this:

 

 

 If(Connection.Connected,
 If(
        !IsEmpty(localCol),
        ForAll(
            matlist,
            Patch(
            )
        )
    );
   clear(localCol);
   SaveData(
        localCol,
        "savedlocalCol"
    );

 

 

Inside the "if connected" i do this same formula for all local collections. The entire app works just like i want it to work but the errors are annoying 😕

 

Kind regards,

Anthony

Anonymous
Not applicable

Hey there,

 

Did you ever figure this one out? I'm getting the same error trying to attach a SP Picture Library to my Gallery, works fine on other Picture LIbrary but its just this one that doesn't work I'm getting the error

 

Helpful resources

Announcements
Power Apps News & Annoucements carousel

Power Apps News & Announcements

Keep up to date with current events and community announcements in the Power Apps community.

Community Call Conversations

Introducing the Community Calls Conversations

A great place where you can stay up to date with community calls and interact with the speakers.

Power Apps Community Blog Carousel

Power Apps Community Blog

Check out the latest Community Blog from the community!

Top Solution Authors
Top Kudoed Authors
Users online (2,828)