cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
SUPRIYAK
Helper I
Helper I

screen navigation issue

Set(var_Param,Param("AOA_Link"));

Set(Var_Eqp_Selected_1, LookUp(AOA_TPT_FT_startup_SK,AOA_Name=var_Param,Equipment_Name));
Set(Var_Rot_Selected, LookUp(AOA_TPT_FT_startup_SK,AOA_Name=var_Param,ROUTE));


If(Var_Rot_Selected = "OP Proc",

Set(Var_Befout_Count, First(Sort(Filter(AOA_TPT_outage_demo6_SK,field_1=Var_Eqp_Selected_1, field_2="Before Outage"),ID,Descending)).field_3);
Set(Var_Outage_Count, First(Sort(Filter(AOA_TPT_outage_demo6_SK,field_1=Var_Eqp_Selected_1, field_2="Outage"),ID,Descending)).field_3);
Set(Var_Befser_Count, First(Sort(Filter(AOA_TPT_outage_demo6_SK,field_1=Var_Eqp_Selected_1, field_2="Before Service"),ID, Descending)).field_3);
Set(Var_Service_Count, First(Sort(Filter(AOA_TPT_outage_demo6_SK,field_1=Var_Eqp_Selected_1, field_2="Service"),ID,Descending)).field_3);

Refresh(AOA_TPT_Outage_Process_Demo_Response_SK1);

If(Value(LookUp(AOA_TPT_Outage_Process_Demo_Response_SK1,And(Equip_Name=Var_Eqp_Selected_1, Response=Blank()),ID))=0,
ClearCollect(Clc_selected_equip_1,Filter(AOA_TPT_outage_demo6_SK, field_1=Var_Eqp_Selected_1));

ForAll(Clc_selected_equip_1,
Patch(AOA_TPT_Outage_Process_Demo_Response_SK1,Defaults(AOA_TPT_Outage_Process_Demo_Response_SK1),
{Equip_Name:field_1,
Outage_Step:field_2,
S_No:field_3,
Res_Dept:field_4,
Check_Type:field_6,
Check_Para:field_5}));

);

ClearCollect(Clc_Befout_list,AddColumns(FirstN(Filter(Sort(AOA_TPT_Outage_Process_Demo_Response_SK1,ID,Descending), Equip_Name=Var_Eqp_Selected_1,Outage_Step="Before Outage"),Var_Befout_Count),"Temp_Status",
If(Response=Blank(),"Pending","Completed")));

ClearCollect(Clc_Outage_list,AddColumns(FirstN(Filter(Sort(AOA_TPT_Outage_Process_Demo_Response_SK1,ID,Descending), Equip_Name=Var_Eqp_Selected_1,Outage_Step="Outage"),Var_Outage_Count),"Temp_Status",
If(Response=Blank(),"Pending","Completed")));

ClearCollect(Clc_Befser_list,AddColumns(FirstN(Filter(Sort(AOA_TPT_Outage_Process_Demo_Response_SK1,ID,Descending), Equip_Name=Var_Eqp_Selected_1,Outage_Step="Before Service"),Var_Befser_Count),"Temp_Status",
If(Response=Blank(),"Pending","Completed")));

ClearCollect(Clc_Service_list,AddColumns(FirstN(Filter(Sort(AOA_TPT_Outage_Process_Demo_Response_SK1,ID,Descending), Equip_Name=Var_Eqp_Selected_1,Outage_Step="Service"),Var_Service_Count),"Temp_Status",
If(Response=Blank(),"Pending","Completed")));

Navigate(Scrn_Outage_List_OP_Proc,ScreenTransition.Cover),


Set(Var_Rot_Selected_Cond,Var_Rot_Selected);
Set(Var_Eqp_Selected_Cond,Var_Eqp_Selected_1);
ClearCollect(Clc_Route_A_Equip_List,Filter(AOA_TP_FP_Integrated_Checklist_SK,ROUTE="Route A"));
ClearCollect(Clc_Route_B_Equip_List,Filter(AOA_TP_FP_Integrated_Checklist_SK,ROUTE="Route B"));
ClearCollect(Clc_Route_C_Equip_List,Filter(AOA_TP_FP_Integrated_Checklist_SK,ROUTE="Route C"));
ClearCollect(Clc_LA_Equip_List,Filter(AOA_TP_FP_Integrated_Checklist_SK,ROUTE="LA Check"));

ClearCollect(Clc_Equip_List_1,Filter(AOA_TPT_FT_startup_SK,ROUTE="OP Proc"));

ClearCollect(Clc_Equip_List_1,Filter(AOA_TPT_FT_startup_SK,ROUTE=Var_Rot_Selected));

ClearCollect(Clc_Check_List_1,Filter(AOA_TP_FP_Integrated_Checklist_SK,Equipment_Name=Var_Eqp_Selected_Cond));

If(Var_Rot_Selected_Cond="LA Check",ClearCollect(Clc_Check_List_2,FirstN(Filter(Sort(AOA_FT_Response_SK,ID,Descending),Equipment_Name=Var_Eqp_Selected_Cond),6));
Set(Var_LA_Cphase_prev_count,LookUp(Clc_Check_List_2,Value(Check_Sr_N)=6,Response_Value));
Set(Var_LA_Bphase_prev_count,LookUp(Clc_Check_List_2,Value(Check_Sr_N)=4,Response_Value));
Set(Var_LA_Aphase_prev_count,LookUp(Clc_Check_List_2,Value(Check_Sr_N)=2,Response_Value));,"");

Navigate(Scrn_CheckList,ScreenTransition.Cover)

);

 

 

I have this code written in 'onstart'. now i am enabling 'navigate in onstart' for making this code work. but still earlier when code was wroking fine then on playing this screen, i was navigated directly to  Scrn_route_list , but now I am navigated to Scrn_CheckList, which i dont want.

 

if i change the required screen name in the last line of code, then deep linking does not work properly. Kindly help

0 REPLIES 0

Helpful resources

Announcements
User Group Leader Meeting January 768x460.png

Calling all User Group Leaders!

Don't miss the User Group Leader meetings on January, 24th & 25th, 2022.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Top Solution Authors
Top Kudoed Authors
Users online (2,748)