cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper II
Helper II

send a camera photos collection with email

a while ago I built an application that send a collection using powerapps by email. The below was working:

 

 

Collect(Photos,{Name:"Photo"&X&".jpg",ContentBytes:Camera3.Photo,'@odata.type':""});Set(X,X+1)

 

Office365.SendEmail(Emailaddress.Text,"Device Report",HtmlText1.HtmlText,{Attachments:Photos,IsHtml:true});Navigate(SuccessMsg,ScreenTransition.Fade);Navigate(SuccessMsg,Fade)

 

now im getting the below error:

icompatible type. The 'ContentBytes' column in the data source you're updating expects a 'Blob' type and you're using a 'Image' type.

 

can you help me ?

3 REPLIES 3
Highlighted
Community Champion
Community Champion

Re: send a camera photos collection with email

Hi @roncam ,

Shane Young @Shanescows has made a very good video on this subject.

Maybe a revisit of his methodology can be of assistance.

 

Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

Highlighted
Helper II
Helper II

Re: send a camera photos collection with email

thanks for your reply. unfortunately the error im getting above is coming after i followed shane video.

Highlighted
Community Champion
Community Champion

Re: send a camera photos collection with email

Hi @roncam ,

Below is the syntax from a screenshot of Shane's video and yours 

ShaneCollect.png

Collect(
   Photos,
   {
      Name: "Photo"&X&".jpg",
      ContentBytes:Camera3.Photo,
     '@odata.type':""}
);
Set(X,X+1)

Maybe put the variable set at the start, so it has a value for the first pass (but you are probably getting Photo0.jpg).

The second part

ShaneAttach.png

Office365.SendEmail(
   Emailaddress.Text,
   "Device Report",
   HtmlText1.HtmlText, 
   {
      Attachments:Photos,
      IsHtml:true
   }
)

appears to be exactly as per the specs - maybe get rid of the IsHtml - I have never used it and HTML renders perfectly. It is worth a try anyway to see if the specs work without it.

 

Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

 

 

 

 

Helpful resources

Announcements
secondImage

Demo-Extravaganza 2020

Check out these cool Power Apps & vote on your favorite!

secondImage

Community Highlights

Check out whats happening in Power Apps

secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (12,994)