cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Lucas
Advocate V
Advocate V

server response: obeject reference not set to an instanceof an object

Hello community,

 

I'm getting this error message "server response: obeject reference not set to an instanceof an object" when I'm trying to submit my form. It was working fine before, and all of sudden this error started to pop-up.

 

I'm using the "Vendor invoice line" from the CDS,and from what I see the problem is under the data card "Sequence" with the "update" property set to:

 

Value(Max('Sales invoice line',Sequence)+1)

I changed it from that code to simply update from the Data Card Value, but the error keeps apearing every time I try to submit it.

 

Any thoughts about what can be causing this error? 

7 REPLIES 7
Lucas
Advocate V
Advocate V

Server error.jpg

 

I tried to isolate the form and re-type the sequence code, but when I finished typing the max code, it stayed ok for a few seconds and the I changed to red underline and the error appears again.

 

I didn't even try to submit or to run the screen.

Update:

 

I went to the CDS to see the data in the vendor invoice line entity and it didn't load, so I decide to look it in excel and the same error message appears.

 

Server error in excel.jpg

 

Is my entity broken for some reason ?

 

Hi @Lucas,

 

Thanks for reporting this.

Would it be convenient for you to share the Session ID, also with the information under your Environments (Created time, location)?

Under Account->Diagnostics->Session Details

I will forward this for further investigation.

Regards

 

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helloe @v-micsh-msft

 

My Session ID: 2ce1c7d0-b311-eaf0-019a-d0ff640fd3fa

 

PowerApps Version 2.0.592

 

Environment: Test Environment

Region

United States

Created by

Lars Peterson

Created

27/01/2017 10:40:14

 

The entity with issues: Vendor invoice line

 

Hi @Lucas,

 

Thanks for the information.

If I have any feedback, I will post back.

Regards

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi @Lucas,

 

CDS data now should be OK to load, would you please take a check again?

Regards

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi @v-micsh-msft,

 

From the browser view, it says there is no data.

 

From the excel view it keeps saying the same error message.

 

browser view and excel view.jpg

 

It should be data there, may be it was erase ?

 

 

Thank you for your replay.

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (1,884)