cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
MichaelSaroka
Advocate I
Advocate I

updating a solution does not update flows

When I export a solution from the sandbox environment and import it into the production environment the flows are not updated.  The only way I managed to get the solution updated was to delete the solution in the production environment.  This deleted all the custom records.  So that is not the answer.  I've both options while importing neither seems to make a difference.

13 REPLIES 13

@MichaelSaroka 

 

Thanks for clarifying.  I have now removed this unmanaged layer. However, after checking my other flows in the solution deployed to production: do I need to do the same ,  before or after I deploy solution from my dev/sandbox environment. 

I guess most peeps are now putting this type of task in a DevOps pipeline but I was hoping to do all this manually until after Go Live. Is this really ALM nirvana🙄?

 

 

 

I have to do it after deployment to production on some flows every time.  Mostly I believe it has to do with the connections that are set up after deployment.  The unmanaged layer saves the new connections along with the old flow.  If it would only save connection info then we wouldn't be having this problem.

@MichaelSaroka 

 

If the the unmanaged layer saves the connections ( via connection references)   I still don't understand why this is blocking the upgrade.  Out of interest, have you tried the 3rd, Update option when you manually import the new  managed solution in your destination environment - looks promising.

 

On Friday, during UAT one of my Power Apps didn't upgrade, which again I resolved by deleting the unmanaged layer.  Today, during further testing, we noticed in the same Power App , the called Power Automate was showing as not connected.  This I had to fix in production as the issue is not showing in the Development environment.  I beginning to think  Power Platform's implementation of  seamless ALM  is laughable . 

 

 

I also don't understand why it saves the whole flow in the active layer instead of just connection information.  I've tried every import option there is and it is all the same. It is also only for flows with certain connection types. 

Helpful resources

Announcements
PA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

This training provides practical hands-on experience in creating Power Apps solutions in a full-day of instructor-led App creation workshop.

Microsoft Build 768x460.png

Microsoft Build is May 24-26. Have you registered yet?

Come together to explore latest innovations in code and application development—and gain insights from experts from around the world.

May UG Leader Call Carousel 768x460.png

What difference can a User Group make for you?

At the monthly call, connect with other leaders and find out how community makes your experience even better.

Top Solution Authors
Top Kudoed Authors
Users online (3,184)