cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
MichaelSaroka
Advocate I
Advocate I

updating a solution does not update flows

When I export a solution from the sandbox environment and import it into the production environment the flows are not updated.  The only way I managed to get the solution updated was to delete the solution in the production environment.  This deleted all the custom records.  So that is not the answer.  I've both options while importing neither seems to make a difference.

1 ACCEPTED SOLUTION

Accepted Solutions

The issue is the active layer , that's why you are not able to see the changes.  

you will have to remove any active layers on the flows and try the import.

can you try that?

View solution in original post

13 REPLIES 13
jekakou
Community Support
Community Support

Hello @MichaelSaroka 

 

Thank you for your post. 

You don't have to remove the whole solution because you will lose data. 

If you have issue with update flows, please check the solution layers of that flow, it might be on the active layer.  

You can remove the flow by removing it from the solution, upgrade it and re-import it back with the changes

 

Thank you

Because the flow is part of a managed solution when imported into the environment, the flows cannot be removed or deleted

If you dont own the solution, could you please check the flow when you are importing to see if there is any active layer?

The flow itself is only one unmanaged layer in the sandbox.  When importing as a managed solution in the production environment, it only has the same single layer (only managed), with one unmanaged layer on top because custom connectors do not import properly and new connections need to be made to access AzureFunctions.

The issue is the active layer , that's why you are not able to see the changes.  

you will have to remove any active layers on the flows and try the import.

can you try that?

View solution in original post

That was the problem for sure.  Thank you.  Sorry for the late reply, I had to have it happen again to test.

 

I wish there was an error about not being able to delete the old flow during import.

Thanks for you comment @jekakou !

 

I was in the same problem. To solve it I delete the Unmanaged solutions layer(the active one) and then automatically I can see the changes in my Power Automate flow.

@akandis   I have the same issue although this seems to occur occasionally. What do you meant by 

"delete the Unmanaged solutions layer ( the active one) " ? .  In my case the flow in the Unmanaged Solution ( Development Sandbox)  is fine , but the one in my Production environment is old. 

Do I simply delete the flow in the managed solution? 

 

Also, going forward how do I guarantee that when I do and export (unmanaged)  then import (managed) that all flows and power apps are updated.  Currently it can be lottery wrt to the flows, which doesn't engender confidence with my end client.

 

 

 

Go to the flow in the managed solution and click on the ellipse (...) next to the flow and select show solution layers.  There should be an unmanaged layer.  You can remove it there as it is overwriting the changes of the new solution.

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Users online (1,339)