cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jrafael83
Level: Power Up

After Unlocking a DataCard to Enable Cascade DropDown it does not Stores any value

I am trying to customize the Add/Edit forms for a custom list to allow the user to select options in a Cascade manner. The user must select a Customer and based on the choice the ComboBox for the Projects is filtered (showing only the projects from the selected customer).

 

I was able to solve how to filter the values by unlocking the Data Card and adding a new DataSource pointing to the "Projects" list, then on the Items property I added Filter('Projects',Customer.Id=DataCardValue2.Id), DataCardValue2 is the ComboBox that shows the Customers, the Title field will be the DisplayField and SearchField.

 

When I select a Customer it successfully filters the values on the Projects combobox, but when I select a Project value and click on Save it does not stores the selected value, it stores Null.

 

The Update property of the DataCard containing the Projects combobox is successfully tied to the ComboBox.Selected and the DataCard is also tied to the "Project" column of the main data source.

 

What am I missing.

 

PS.

When I delete the card and add the default card (with no cascade) it stores the data successfully, but I need the cascade and when I made the change to filter the data (cascade) it stops working.

1 ACCEPTED SOLUTION

Accepted Solutions
jrafael83
Level: Power Up

Re: After Unlocking a DataCard to Enable Cascade DropDown it does not Stores any value

OK, I found the solution to my problem in another post from this community, here it is: https://powerusers.microsoft.com/t5/General-Discussion/Can-t-save-data-in-Combo-Box-filled-with-Clea...

 

This problem happens when we connect a List to a different DataSource other than the default.

View solution in original post

1 REPLY 1
jrafael83
Level: Power Up

Re: After Unlocking a DataCard to Enable Cascade DropDown it does not Stores any value

OK, I found the solution to my problem in another post from this community, here it is: https://powerusers.microsoft.com/t5/General-Discussion/Can-t-save-data-in-Combo-Box-filled-with-Clea...

 

This problem happens when we connect a List to a different DataSource other than the default.

View solution in original post

Helpful resources

Announcements
firstImage

Microsoft Business Applications Virtual Launch Event

Join us for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

FirstImage

Power Platform World Tour

Coming to a city near you

thirdimage

PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

FourthImage

Join PowerApps User Group!!

Connect, share, and learn with your peers year-round

Top Kudoed Authors
Users Online
Currently online: 524 members 4,710 guests
Recent signins:
Please welcome our newest community members: