cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
DTreg1
Level 8

BUG: Camera has flipped for no reason with PowerApps Release 3.18064.24

Hello,

 

I'm in the process of building an app, I have been using the camera. This morning, while testing the app, the camera changed from the back of the phone to the front. I checked the Camera setting, no change, still 1. I reversed it to 0 and now the camera is back on the back of the phone but when I view it on the PC, it's opposite of what the phone is everytime.

 

Issue with the new PowerApps app possibly? App Version 3.18064.29

 

Workaround: I created an UpdateContext to manually change it in the app.

2 REPLIES 2
Community Support Team
Community Support Team

Re: BUG: Camera has flipped for no reason with PowerApps Release 3.18064.24

Hi @DTreg1,

 

Could you please share a bit more the issue within your app?

Is the Default value of the Camera property of the Camera control set to 1?

 

I have made a test on my side and don't have the issue that you mentioned.

 

If you want to enable Front camera within your Mobile Device, please set the Camera property of the Camera control to 1. If you want to enable Back camera within your mobile Device, please set the Camera property of the Camera control to 0.

 

In default, the Camera property of the Camera control is set to 0, then the Back camera is enabled within Mobile Device.

 

You could consider take a try to add a Button control within your app to enable/disable the Front camera and Back camera. Please take a try with the following workaround:

Set the OnSelect property of the Button control to following formula:

 

UpdateContext({EnableFront:!EnableFront})

Set the Camera property of the Camera control to following formula:

 

 

If(EnableFront=true,1,0)

 

 

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
DTreg1
Level 8

Re: BUG: Camera has flipped for no reason with PowerApps Release 3.18064.24

Hi Kris,

 

Thank you for the reply, The app I created was actually created back on release: 2.0.750 on 1/22/2018, not 3.18064.24. Therefore, I don't think that's a valid test. I created the camera back then and haven't needed to touch it since while using it (defaulted to "0"). On the latest version of the PowerApps app for iPhone, I turned the app on as normal and the camera was using the front camera instead of the back, with no change to the setup. I believe I also mentioned that while viewing the app through the web version, the camera still works normally, showing the back instead of the front. To me, with no change in the app I created and the web viewer acting as it should, but a new release on the PowerApp app, I'm deducing that there's a bug with the latest release of the PowerApp app. There was also an issue with opening the app (App was created on 1/22/2018) that said "The app didn't install correctly". I was able to fix this by deleting the PowerApps app, restarting the phone and reinstalling it.

 

Hope this helps explain the bug better.

 

Thank you

Helpful resources

Announcements
firstImage

Microsoft Business Applications Virtual Launch Event

Join us for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

FirstImage

Power Platform World Tour

Coming to a city near you

thirdimage

PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

FourthImage

Join PowerApps User Group!!

Connect, share, and learn with your peers year-round

Top Kudoed Authors
Users Online
Currently online: 81 members 3,408 guests
Please welcome our newest community members: