cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Meneghino
Level 10

Bug: Not seeing all tables of SQL Server (Access Web App) in data source list

In the latest version of Studio 2.0.600 both desktop and web truncates the list of tables in my database.

The table are displayed in alphabetical order and only the first 20 rows or so of 45 are shown.

This was not a problem earlier.

Thanks for any input.

 

__.JPG

5 REPLIES 5
Community Support Team
Community Support Team

Re: Bug: Not seeing all tables of SQL Server (Access Web App) in data source list

Hi Meneghino,

 

I created a connection to SQL Server On-premise using Gateway, and I had 28 tables in my database.


On both PowerApps for Windows and PowerApps for Web, the tables are displayed in alphabetical order, and I can get all my tables on “Choose a table” list.


Could you please try again with this issue? I guess it has been fixed now.


If you are still getting the issue, please feel free reply.

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
and_bak
Level: Powered On

Re: Bug: Not seeing all tables of SQL Server (Access Web App) in data source list

I have the same problem. My Ax 2009 sql DB has MANY tables and powerapps stops listing them after n (500???) tables (I have not counted them).

I have re-installed my on-premise gateway and created a new connection, but still same result, the listing stops at the n'th table.

Same result in also in Flow (SQl-server-Get records) but can be worked around with "Custom entry"

!!! Flow (SQL-server - Get record, by record id) shows all my tables !!!

 

Can it be worked around by creating a second dataset (beside "Default") ? But how do you create a dataset to be used with the On-premise gateway?

 

Of course - a serious problem, and I suspect a serious bug?

pcvanrees
Level: Power Up

Re: Bug: Not seeing all tables of SQL Server (Access Web App) in data source list

I have the same problem.

Our database (Mircosoft NAV) have many many tables, much of them are not shown.

Only the first 50 or so, not counted. also the filter didn't help so they seem to be not loaded.

 

Is there a workaround?

moutinhoabreu
Level: Powered On

Re: Bug: Not seeing all tables of SQL Server (Access Web App) in data source list

I've found out only tables with identity are showing

Highlighted
JustinCale
Level: Power Up

Re: Bug: Not seeing all tables of SQL Server (Access Web App) in data source list

I can confirm this, I am trying to use a connection to the standard AspNetUsers table which has nvarchar as an ID and cannot be made the Identity. I don't really want to start adding identity fields to standard tables. Will there be a fix for this? Can the connection not use the primary key instead?

Helpful resources

Announcements
firstImage

PowerApps Monthly Community Call!

Join us next Wednesday for our Demo Extravaganza, October 16, 2019 8am PDT.

firstImage

Microsoft Business Applications Virtual Launch Event

Join us for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

FirstImage

Power Platform World Tour

Coming to a city near you

thirdimage

PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

FourthImage

Join PowerApps User Group!!

Connect, share, and learn with your peers year-round

SecondImage

Power Platform Summit North America

Register by September 5 to save $200

Top Kudoed Authors
Users Online
Currently online: 310 members 4,514 guests
Please welcome our newest community members: