cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted

Gallery Image doesn't display after collection update

I have a gallery bound to a collection. I have an add media control, and a button that adds the photo and other data to my collection.

If I use UpdateIf to update a column in the collection, my images don't all display. In my production app, only the first image displays. In my test app to try to isolate the issue, the first and last image display.

 

Here is a screenshot from a sample app where I was trying to isolate the issue. The formula on "Add" is:

Collect(Pictures, {Photo: AddMediaButton1.Media, Submitted: false, PhotoName: Text(Now(), "[$-en-US]YYYY_DD_MM_HH_mm_ss")})

The Gallery is bound to the Pictures collection. The label that displays "false" is the Submitted field - and the other label is the Photo data:
scrn3.png
The formula on the "Update" button is:

UpdateIf(Pictures, Submitted = false, {Submitted: true})

After I click the button, you can see in this next screenshot that Submitted is now set to true - but two images no longer display:

scrn4.png

Any thoughts as to the cause of this behavior? I have a workaround in place in my production app, but I'd like to know if this behavior is anticipated or known.

2 REPLIES 2
Community Support Team
Community Support Team

Re: Gallery Image doesn't display after collection update

Hi @hilary_stoupa,

 

I just created the same app following your steps and I cannot reproduce your issue. Here is my steps:

 

1. Add an image file to the AddPicture control.

2. Click on "Add" button -> a new record is added to Gallery.

3. Click on "Update" button -> The "false" field would change to "true" and the picture still shows correctly.

 

1.PNGCapture.PNG

 

Please check if this issue only happens to specific images since I cannot reproduce it. 

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Re: Gallery Image doesn't display after collection update

No, it doesn't seem to be related to the image file. As long as I have more than one image in the gallery, when I execute the UpdateIf, images stop displaying. Like I said - it is somewhat random - in my sample app, the first and last image still display. In my production app (on a different tenant) only the first still displays.

Helpful resources

Announcements
firstImage

PowerApps Monthly Community Call!

Join us next Wednesday for our Demo Extravaganza, October 16, 2019 8am PDT.

firstImage

Microsoft Business Applications Virtual Launch Event

Join us for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

FirstImage

Power Platform World Tour

Coming to a city near you

thirdimage

PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

FourthImage

Join PowerApps User Group!!

Connect, share, and learn with your peers year-round

SecondImage

Power Platform Summit North America

Register by September 5 to save $200

Top Kudoed Authors
Users Online
Currently online: 322 members 4,080 guests
Please welcome our newest community members: