cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
DaveBoehm
Level: Power Up

Getting your data...

I've seen 9 posts on this, but no solutions.

 

I'm getting the same error.  In my case, I am connecting to Dynamics 365 Business Central.  I'm doing this from a "Canvas".  I am able to connect, and choose a table for my app.  I am then allowing PowerApps to populate the form with my fields.  I then save the app, and run it.  When I do this, it simply hangs.

 

I've tried to do a "Crtl-Righ Click", but this doesn't retrieve a session ID (or anything else).  I find it strange that I can connect and select a table, but get no data when I try run the app.

 

Any ideas?  Thanks!

3 REPLIES 3
PowerApps Staff Mr-Dang-MSFT
PowerApps Staff

Re: Getting your data...

Hi @DaveBoehm,

You can get a session id with these instructions:

https://aka.ms/pa/sessionid

 

When you say the app 'hangs,' what does that look like? What screen is that on? What do you see? 

 

Can you also provide a screenshot of what you mean when you 'get no data'?

DaveBoehm
Level: Power Up

Re: Getting your data...

Mr. Dang,
 
Thanks for responding.
 
Please see attached screen shot for error message.
 
Session details (when editing):
 
Session ID: 7cd1bcf1-c0fd-4b02-befe-e61f4add75e8
PowerApps 3.18114.26
 
 
Session details (when app is running):
 
Session ID: 0d7c7d30-72b7-4057-bbe3-45cfa913eb51
PowerApps 3.18114.16
 
 
App ID:
41233d43-3a9f-4b7d-9e59-ac91fa088ff1
 
BTW, I created two apps yesterday that both access online Business Central.  Both apps give me the "getting your data..." message.  I allowed one to stay open on my screen for about 1/2 hour just to be sure it was truly hanging.
 
 

--Dave--

Community Support Team
Community Support Team

Re: Getting your data...

Hi @DaveBoehm,

Have you taken a try to run your app within Preview Mode? Does this issue also occur?

Which browser do you use to run your published app?

I have made a test on my side, and don't have the issue that you mentioned. Please take a try to run your app within Preview Mode, then check if the issue still exists.

Please consider take a try to turn off/disable the "Improved app rendering (final validation)" option and "Delayed load" option within Advanced settings of App settings, then re-publish your app, run your app again to check if the issue is solved.

In addition, please consider take a try to clear cache of your browser, then run your app again, check if the issue still exists.

If the issue still exsits, please consider submit an assisted support ticket through the following link:

https://powerapps.microsoft.com/en-us/support/pro/

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
firstImage

PowerApps Monthly Community Call!

Join us next Wednesday for our Demo Extravaganza, October 16, 2019 8am PDT.

firstImage

Microsoft Business Applications Virtual Launch Event

Join us for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

FirstImage

Power Platform World Tour

Coming to a city near you

thirdimage

PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

FourthImage

Join PowerApps User Group!!

Connect, share, and learn with your peers year-round

SecondImage

Power Platform Summit North America

Register by September 5 to save $200

Top Kudoed Authors
Users Online
Currently online: 231 members 4,885 guests
Please welcome our newest community members: