cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Super User
Super User

Re: Improved app rendering issues

AH HAAAAA~! 

 

Toggled "Delayed Load" to "OFF", then "Enhanced Rendering" to "ON", Save, Close, Open

 

NOW the Combobox works in both IDE and IDE Preview.

 

Thank you for the prompt response. Just in the knick of time for a release tomorrow.

jlister
Level 8

Re: Improved app rendering issues

@_Corey_  Thanks for the update and I look forward to receiving the updated version. To answer your question, I don't believe I had closed & reloaded the application after changing the improved app rendering feature.
However, I now have followed the suggested steps, and when improved app rendering is enabled the combo box does align properly in the web browser studio. Additionally, I can confirm that the options are now visible in the list box control. However, I am noticing a wierd behavior when scrolling a gallery list when using the app in iOS mobile. The items in the gallery are not scrolling smoothly. It gives the items a jittery appearance rather than a smooth scrolling effect. Sorry, I am not sure how else to describe the scrolling, but it is abnormal. Hopefully, you will be able to replicate this issue and find a fix. Please let me know if you require any additoinal information.

PowerApps Staff _Corey_
PowerApps Staff

Re: Improved app rendering issues

@ericonline I'm surpised delayed load had to be turned off, but I'm glad it worked for you none-the-less! Smiley Happy

 

@jlister I'm glad that Improved App Rendering is working for ComboBox and ListBox!  RE: scrolling, we are aware of an issue when Improved App Rendering is enabled; it is being tracked separately.

Super User
Super User

Re: Improved app rendering issues

Hi @_Corey_. I'm absolutely certain that the problem remained in the IDE and IDE Preview until I toggled "Delayed Load". 

 

Unless there was a time delay of some kind in the background running. 

 

Either way, the PowerApps response time was awesome and we were able to keep our project timelines going. 

 

Thanks for all the hard work and for the amazing toolset. 

 

Highlighted
systemcrash
Level: Powered On

Re: Improved app rendering issues

I did 

"Toggled "Delayed Load" to "OFF", then "Enhanced Rendering" to "ON", Save, Close, Open"

 

The combo show up correctly indeed (not at the bottom anymore) but I still CAN'T select any item in IDE and IDE preview.

 

 

PowerApps Staff _Corey_
PowerApps Staff

Re: Improved app rendering issues

@systemcrash This is odd behaviour indeed.  What is your OS/browser combination? Also, what type of data-source is the ComboBox connected to?

jlister
Level 8

Re: Improved app rendering issues

@_Corey_ Is there a way to follow the progress on this particular issue? I would like to use classic mode until this issue is fixed, so being able to know when the scrolling issue is reolved would be helpful.

A few things that prevent me from using the Improved app rendering:
1) The screen transitions are slower. Parts of the previous screen and current screen are shown together for half a second. Not a smooth transition which most end-users have become acustomed to. 
2) Formulas activated in the OnVisible are delayed. IE. I use a context variable to determine visibility for a label. When using the new render mode, everything is visible by default until a half second later, the variable is then updated after the OnVisible action runs and the label visibility property is set to "false".
3) Items in a gallery list do not scroll smoothly.
4) Autoheight on labels does not work. Text is cut-off on screen.

I hope this information is helpful and can be resolved before removing the classic rendering mode.

Thank you.

systemcrash
Level: Powered On

Re: Improved app rendering issues

Hi,

 

My os is windows 10

Browser is Google Chrome : 69.0.3497.100

The Data Source is linked with a SharePoint List.

 

 

systemcrash
Level: Powered On

Re: Improved app rendering issues

Just did test with Edge and I got the same result.

systemcrash
Level: Powered On

Re: Improved app rendering issues

With the release of 3.18101.  I still have issue with combo box in IDE Mode.

 

Here's a simple example where I it show a combo box connected on a sharepoint list containing provinces.  On "play" mode there's no issue.  On IDE preview mode.... you can't change value on combo box.

 

 

Helpful resources

Announcements
firstImage

PowerApps Monthly Community Call!

Join us next Wednesday for our Demo Extravaganza, October 16, 2019 8am PDT.

firstImage

Microsoft Business Applications Virtual Launch Event

Join us for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

FirstImage

Power Platform World Tour

Coming to a city near you

thirdimage

PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

FourthImage

Join PowerApps User Group!!

Connect, share, and learn with your peers year-round

SecondImage

Power Platform Summit North America

Register by September 5 to save $200

Top Kudoed Authors
Users Online
Currently online: 380 members 4,277 guests
Please welcome our newest community members: