cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
BrettR
Level: Powered On

Issue with Gallery connected to SharePoint List

Hi all,

      I am having a peculiar issue with a Gallery that has a checkbox on the items, and navigating to a different screen.

 

I have two screens.

 

Screen 1 contains a gallery with a SharePoint list as it's data source.  I have added a 'Checkbox' control onto the gallery so that people can select items from the gallery and the 'OnCheck' property saves the item to a Collection.

 

The problem comes when I click a button on Screen 1 that has the 'OnSelect' property set to Navigate(screen2,transition.none).  When viewing the PowerApp outside the studio, Clicking the button seems to make the Gallery flicker once, then anything that was selected in the Checkbox disappears.  

 

This annoyingly only happens on the first click of the button, if I go back to screen 1 and make some more selections, on second click, the selections stay as expected.

 

Any ideas?

1 ACCEPTED SOLUTION

Accepted Solutions
MarcBailey
Level 8

Re: Issue with Gallery connected to SharePoint List

Hi BrettR,

 

I have encountered a similar problem in the past.  I worked with the PowerApps Product Team and it was determined that there is a bug related to the syntax (I spoke with them last week and they are working on a fix): 

 

Gallery.Selected and Gallery.AllItems

 

I had to go back and switch everything to ThisItem.Column and similar workarounds.  Before I did the workarounds I was having problems with OnSelect -- Navigate and other controls where I would have to click the twice before they would work.

 

Let me know if this help.  Thanks, Marc...

View solution in original post

3 REPLIES 3
MarcBailey
Level 8

Re: Issue with Gallery connected to SharePoint List

Hi BrettR,

 

I have encountered a similar problem in the past.  I worked with the PowerApps Product Team and it was determined that there is a bug related to the syntax (I spoke with them last week and they are working on a fix): 

 

Gallery.Selected and Gallery.AllItems

 

I had to go back and switch everything to ThisItem.Column and similar workarounds.  Before I did the workarounds I was having problems with OnSelect -- Navigate and other controls where I would have to click the twice before they would work.

 

Let me know if this help.  Thanks, Marc...

View solution in original post

BrettR
Level: Powered On

Re: Issue with Gallery connected to SharePoint List

Cheers Marc! That sounds exactly the same.  I'll test and get back to you Smiley Happy

ofs
Level: Powered On

Re: Issue with Gallery connected to SharePoint List

Any updates about this issue? I have almost the same setups and issue here. So far I plan to let users re-check the checkboxes in the list (Because it seems working after moving back to the screen with the gallery).
[UPDATE] When this happens, it seems the gallery still have the old collections which you cannot see visibly since checkboxes are reseted.

I hope I will be able to provide my app without any issue as soon as possible.

 Please let me know if any update or solution for this. Thank you!

Helpful resources

Announcements
firstImage

Microsoft Business Applications Virtual Launch Event

Join us for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

FirstImage

Power Platform World Tour

Coming to a city near you

thirdimage

PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

FourthImage

Join PowerApps User Group!!

Connect, share, and learn with your peers year-round

Top Kudoed Authors
Users Online
Currently online: 411 members 3,108 guests
Please welcome our newest community members: