cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
CABIRD
Level: Powered On

Media - Camera - blank

Hello

 

Recently adding Media>Camera the webcam remains blank i.e. no camera display. Webcam works fine with MS Teams for example but not in Power Apps.

 

Message reads 'Your camera isn't setup or you are already using it.'

 

I've signed out of Teams. Windows 10 Camera app there appears no way to disconnect connection although I haven't initiated the app. If I run the Camera app the webcam works perfectly.

 

Clearly I'm missing something.  Not a major issue as app would be used for a mobile audit Power App but not having to switch between desktop and mobile would be good for testing.

 

Camera.png 

1 ACCEPTED SOLUTION

Accepted Solutions
Super User
Super User

Re: Media - Camera - blank

A couple of things to check out.

 

  1. Make sure your camera is a approved for use in the browser where you are running PowerApps studio.  This is one of the common reasons that the app can't access the camera.
  2. If your computer has more than one camera make sure it is trying to use the correct one.  For example, surface tablets have a front and a back camera.  You can control which one the application is trying to use by changing the number in the Camera property of the camera control. for example, 0, 1,2, etc.


-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.
2 REPLIES 2
Super User
Super User

Re: Media - Camera - blank

A couple of things to check out.

 

  1. Make sure your camera is a approved for use in the browser where you are running PowerApps studio.  This is one of the common reasons that the app can't access the camera.
  2. If your computer has more than one camera make sure it is trying to use the correct one.  For example, surface tablets have a front and a back camera.  You can control which one the application is trying to use by changing the number in the Camera property of the camera control. for example, 0, 1,2, etc.


-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.
CABIRD
Level: Powered On

Re: Media - Camera - blank

Hello @Pstork1 

 

Thank you for taking the time to respond.

 

Sadly adjusting browser to approve camera didn't overcome the issue. Odd as until recently I had no issue with the camera. Probably an update has changed configuration requirements.

 

However I found a way around the issue. Use Power App desktop app. Good for testing (for now). Rather iterating to have to switch between desktop development and phone.  

 

Best regards

Christopher

Helpful resources

Announcements
firstImage

PowerApps Monthly Community Call!

Join us next Wednesday for our Demo Extravaganza, October 16, 2019 8am PDT.

firstImage

Microsoft Business Applications Virtual Launch Event

Join us for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

FirstImage

Power Platform World Tour

Coming to a city near you

thirdimage

PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

FourthImage

Join PowerApps User Group!!

Connect, share, and learn with your peers year-round

SecondImage

Power Platform Summit North America

Register by September 5 to save $200

Top Kudoed Authors
Users Online
Currently online: 491 members 5,203 guests
Please welcome our newest community members: