cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ShaneCluning
Level: Powered On

Nested Gallery, 1st Item not displaying sub gallery items

Hi,

 

So I have an issue with nested Galleries, the top level gallery (Contracts) has a sub gallery (References) for each item (contract).

In the first top level item (contract) the sub gallery (references) always shows no items, for every subsequent item (contract) the sub gallery works properly (showing the references).

 

This happens always to the first item in the top gallery, regardless of sorting, I've checked my gallery items filter and its working properly (checked via text box within the contract item showing the count of references), just the gallery doesnt work.

 

Screenshot 1: Showing contract 1 having no items listed
Ascending Sort.png

Screenshot 2: Showing contract 2 having no items listed

Descending Sort.png

1 ACCEPTED SOLUTION

Accepted Solutions
PowerApps Staff SpencerLynn
PowerApps Staff

Re: Nested Gallery, 1st Item not displaying sub gallery items

Hi @ShaneCluning,
 
We are aware of the issue and are working on a fix for this issue.
 
As a work around, can you try to wrap the gallery (the one that isn't rendering the first item) items using the FirstN function?

 

FirstN(<CurrentItems>, <MaxExpectedItems>) 

 

View solution in original post

9 REPLIES 9
Community Support Team
Community Support Team

Re: Nested Gallery, 1st Item not displaying sub gallery items

Hi @ShaneCluning,

 

Thanks for the feedabck.

Issue confirmed from my side.

I will help collect this, and if I got any response, I will post back.

In addition, as a workaround, would it be available for you to switch to the other controls such as dropdown, or list box?

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
PowerApps Staff SpencerLynn
PowerApps Staff

Re: Nested Gallery, 1st Item not displaying sub gallery items

Hi @ShaneCluning,
 
We are aware of the issue and are working on a fix for this issue.
 
As a work around, can you try to wrap the gallery (the one that isn't rendering the first item) items using the FirstN function?

 

FirstN(<CurrentItems>, <MaxExpectedItems>) 

 

View solution in original post

ShaneCluning
Level: Powered On

Re: Nested Gallery, 1st Item not displaying sub gallery items

Hi SpencerLynn,

 

Wrapping the Filter inside of a FirstN seems to solve the problem for now Smiley Happy Thanks for the heads up.

 

Cheers,

Shane

 

JRaasumaa
Level 10

Re: Nested Gallery, 1st Item not displaying sub gallery items

I just hit this issue too and it's a show stopper for us on a bunch of data gathering. Any update as to why this is happening? 

 

 

edit: I tried wrapping the sub gallery filter with a FirstN and it did show the first set of results. 

janewald
Level: Powered On

Re: Nested Gallery, 1st Item not displaying sub gallery items

Hi, I have got the same issue. In the web editor, the items of the inner gallery belonging to the first item of the outer gallery are only displayed sometimes. Is there still no other workaround than using FirstN and CountRows?

janewald
Level: Powered On

Re: Nested Gallery, 1st Item not displaying sub gallery items

Actually, I have just tried the FirstN solution and it does not work for me when working with a data source like Excel Online. As soon as I work with the exact same data from gallery, it works again. This needs to be fixes

lknudson
Level: Powered On

Re: Nested Gallery, 1st Item not displaying sub gallery items

This issue shows "solved".  A work-around is not really a solution, particularly when the work-around requires using a 'non-delegable' function.  I hope a real solution is still being pursued.

Tim78
Level: Powered On

Re: Nested Gallery, 1st Item not displaying sub gallery items

Just hit this issue too. I can't say the issue is solved but the work around got me past it.

MrSchu02
Level: Powered On

Re: Nested Gallery, 1st Item not displaying sub gallery items

Hello,

 

Is this still the best workaround for the issue? I am addressing delegation within my app and FirstN is a non-delegable function.

 

Thanks

Helpful resources

Announcements
firstImage

Microsoft Business Applications Virtual Launch Event

Join us for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

FirstImage

Power Platform World Tour

Coming to a city near you

thirdimage

PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

FourthImage

Join PowerApps User Group!!

Connect, share, and learn with your peers year-round

Top Kudoed Authors
Users Online
Currently online: 88 members 3,039 guests
Please welcome our newest community members: