cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
JenVitug
Level 8

Re: No data source provided error

hi @Anonymous,

I got the same issue started yesterday.  at first I thought it might be the network connectivity but then everyone started reporting the issue to me. The app had been working fine past 2 months. The app still able to load the initial welcome/signin and Gallery list screen but when user tries to ADD new record, that's  when the app  shows the blank screen with NoDataSource Provided erro.

 

When i run the app from PowerApps desktop, it runs fine but in mobile phone/tablet and laptop directly from the web.powerapps.com.  it "Crashes"

 

HELP!!! Smiley Sad Smiley Sad Smiley Sad 

JenVitug
Level 8

Re: No data source provided error

could the error be related to PowerApps release version, the new version which started all this "No Data Source Provided" erorr 

started with version release 3.18052.8

 

the previous one 3.18045.15  my app was working perfectly fine Smiley Sad

JenVitug
Level 8

Re: No data source provided error

could the error be related to PowerApps release version, the new version which started all this "No Data Source Provided" erorr 

started with version release 3.18052.8

 

the previous one 3.18045.15  my app was working perfectly fine Smiley Sad

JenVitug
Level 8

Re: No data source provided error

and as a last resort, i tried to restore to the published version on the older PowerApps version release 3.18045.15,  it NO LONGER allowed me to RESTORE Smiley Sad Smiley Sad

JenVitug
Level 8

Re: No data source provided error

hi @v-monli-msft

 

i tried doing 1. Confirmed Datasource is connected correctly. infact the app runs OK when launched from powerapps desktop.

2. I  duplicated the Screen (and deleted the old one)  with the Form that is sending the 'No Data Source Provided" error , but STILL the error persisted

3.  I tried to restore the last GOOD and working version from 5/8  and it WONT allow me to RESTORE !

 

Here is my session ID details , please help Smiley Sad

 

Session ID: e9b47929-63a5-4537-90f4-61284ec626dc
PowerApps 3.18052.6

Django
Level: Powered On

Re: No data source provided error

Hi JenVitug,

I had a similar issue where restoring was not an option (it was working but I did not want to redo all the changes).

Please note that this is still to be considered a bug, but after some intense backtracking (cost me my weekend) I found that referencing labels / datakeys from one screen to another can also cause this issue.

 

In my scenario: I had a Form-Control on Screen5 where I had changed the datacards to take Label.text values from Label-controls on Screen3 (so that if I change it on Screen3, I would not have to change it on other screens (as Microsoft recommends when applying for a PowerApp to be offered in the Store!!!)).

 

After removing all references on Screen5 the issue disappeared --> I also had label-colours+sizes+x+y+width etc referencing to other screens so this can take some time...

JenVitug
Level 8

Re: No data source provided error

@Django i already logged a ticket with Microsoft Support and they have yet to get back to me after ive sent them the network trace and session ID.

 

Some recommended duplicating the SCREEN in error and deleting th original screen and replacing it with the duplicated one, SIMPLY did not work for me.  

Since i could not wait for support guy to get back to me , i completely RE-Created  the  SCREEN in Error, painstakingly.  Of course this solved the problem (at least for my users, they are now able to use th app again)

 

But I still would like to find out what happened to the original screen that is in "No Data Source Provided error".

 

I will try your troubleshooting steps  and try to find cross-Screen referenced labels and see if it solves my app's error (i have saved/renamed  the app into a new name so that i can still try to troubleshoot it separately )

Huub100759
Level: Powered On

Re: No data source provided error

Same problem here!

Unbelievable that this can happen. Working applications suddenly stop working, generating errors.

My confidence in PowerApps (read Microsoft) dropped again!

 

 

Tea4d
Level: Powered On

Re: No data source provided error

Have the same problem is their any help available on this.  I feel like giving up on power apps altogether.

Ronnie
Level: Powered On

Re: No data source provided error

Starting happening to me yesterday evening.  Oddly, none of my form fields work as they should (if I try to use a dropdown, the dropdown does activate or display any of the dropdown choices --- my dropdown looks as if it's become a text field).  If I keep closing and opening the PowerApp, I will randomly get the 'No data source provided' error to show up for ~5 seconds, then the error goes away and my screen displays as it should and works as it should.  Other team members get the same behavior.  We see the issue both in Chrome and Edge.

Helpful resources

Announcements
firstImage

PowerApps Monthly Community Call!

Join us next Wednesday for our Demo Extravaganza, October 16, 2019 8am PDT.

firstImage

Microsoft Business Applications Virtual Launch Event

Join us for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

FirstImage

Power Platform World Tour

Coming to a city near you

thirdimage

PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

FourthImage

Join PowerApps User Group!!

Connect, share, and learn with your peers year-round

SecondImage

Power Platform Summit North America

Register by September 5 to save $200

Top Kudoed Authors
Users Online
Currently online: 276 members 4,536 guests
Please welcome our newest community members: