cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
TCH
Level: Powered On

Patch function not working

Hi everyone, 

fairly new and relative novice at this PowerApps thing. 

I am trying to make an app that makes it possible for my coworkers to "order" lunch, basically just put into a list whether they are eating lunch in the cantina that day so that the kitchen employees can know how much food to prepare. 

I am trying to create an app in which employees can put in the date, their employee number and their initials, and then press "order" and this information will go to a sharepoint list. 

However when i use the Patch or Collect function it doesn't register any of the things i put after "Patch(Listname," it is almost like it does not understand that the comma is there and doesn't allow me to move on so for example when I put "Patch(Listname, Defaults(Listname);" It does not register Defaults or (Listname) the second time, See attached picture. 

Anyone got any idea why this might be, or whether i am just making a mistake, as i said relatively new to this Smiley Happy 

1 ACCEPTED SOLUTION

Accepted Solutions
Super User
Super User

Re: Patch function not working

Hi @TCH 

 

Can you try to use semicolon(Smiley Wink instead of comma(')? This differs location to location. Please try out your expression as:
Patch(Listname;Defaults(Listname);{col1:"Value1"})
 
Hope this Helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

3 REPLIES 3
Super User
Super User

Re: Patch function not working

Hi @TCH 

 

Can you try to use semicolon(Smiley Wink instead of comma(')? This differs location to location. Please try out your expression as:
Patch(Listname;Defaults(Listname);{col1:"Value1"})
 
Hope this Helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

TCH
Level: Powered On

Re: Patch function not working

Thanks very much, that worked like a charm Smiley Happy 

Do you know why that is, every single video or even syntax/function list with explanations, describes how one should use commas? Smiley Happy 

Super User
Super User

Re: Patch function not working

Hi @TCH 

 

There are few things that are based on regional settings in the PowerApps and comma/semicolon is one of them. For most of the locations, comma is supported and hence most of the blogs points towards using it.
 
Hope this Helps!
 
If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Helpful resources

Announcements
firstImage

Microsoft Business Applications Virtual Launch Event

Join us for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

FirstImage

Power Platform World Tour

Coming to a city near you

thirdimage

PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

FourthImage

Join PowerApps User Group!!

Connect, share, and learn with your peers year-round

Top Kudoed Authors
Users Online
Currently online: 288 members 3,527 guests
Please welcome our newest community members: