cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Jek
Level: Powered On

Problem with Add Image Control and appres//blobmanager

I need to get the actual data or URI of a picture, that was added using the "Add Image"-Control.
Instead of the picture data (or URI) I get: 

appres://blobmanager/18f52060d737479cad911665f4e49362/2


Which is completely useless to me.


Is there no way to access the picture data?

And if there isn't why would you even introduce this local reference?
Why would anyone want to load a picture into PowerApps but then not be ablet to process it further?
Either I am missing something or I am doing it wrong.

I am aware of the few (always the same 3) entries that get always posted as an Answer, they don't work for me.

I don't have trouble uploading a picture to Sharepoint, I have trouble getting an actual picture!

(This also seems to be a relatively new problem? In all the older posts people don't seem to have trouble with the actual selection of the picture.)

I am grateful for any help.

1 ACCEPTED SOLUTION

Accepted Solutions
Super User
Super User

Re: Problem with Add Image Control and appres//blobmanager

@NetlogixBI 

 

I posted a video the other day on putting a signature from PowerApps into a pdf document. An image of any sort would work the same. I'm new at the whole "video" thing but check it out and see if it will help with what you are wanting to do. 

 

https://youtu.be/UdbNqQ1z_Ww

 

View solution in original post

16 REPLIES 16
xzDan
Level 8

Re: Problem with Add Image Control and appres//blobmanager

I agree.

I used Attachments instead so that I can get the name, with this as the 'OnAddFile'
Clear(colAttachments);
Collect(colAttachments, AddColumns(RenameColumns(Value_Attachments.Attachments,"Value","ContentBytes"),"'@odata'",""))

And these can then be displayed in a gallery etc.

 

But this has an issue also where the attached image may be removed from the source when it is uploaded via mobile.

Jek
Level: Powered On

Re: Problem with Add Image Control and appres//blobmanager

Thank you, I might try that later on.

Super User
Super User

Re: Problem with Add Image Control and appres//blobmanager

The only one that doesn't pull in like that is the Camera itself. It works fine for displaying back in PowerApps but is useless outside of PowerApps..the Signature is the same way.

 

Couple of work arounds for this but none that I really like. 

 

If uploading I too use the Attachments card and if taking muliple photos I put them in a collection from the Camera control and then upload them with Patch (but to do that you also need a flow to convert them but it isn't as complicated as the other)

 

 

Jek
Level: Powered On

Re: Problem with Add Image Control and appres//blobmanager

Tank you for the Answer. I currently took another approach. But I am still interested in any insight in this subject.

EmmitK
Level: Powered On

Re: Problem with Add Image Control and appres//blobmanager

What I did was put a hidden Image component "Image1" on the page, set its "Image" to the url. When I accessed the Image1.Image property to Patch, it actually sent through the data.

 

Try that and see if it work in your use-case.

Jek
Level: Powered On

Re: Problem with Add Image Control and appres//blobmanager

Thank you for that suggestion, I don't have the time to try it now, but this might help others.

NetlogixBI
Level: Powered On

Re: Problem with Add Image Control and appres//blobmanager

So has anyone solved this problem? My image returns appres://blobmanager/67076544a64c4d2ca2e8d919e4337a1f/13 but i want to convert it to a url so that i can embed in my html. Right now it doesnt render the image in my html.

 

any help would greatly be appreciated. Smiley Happy

Super User
Super User

Re: Problem with Add Image Control and appres//blobmanager

@NetlogixBI 

 

Are you using the 'Add Picture' control the 'Camera'? 

 

And when you say you want it to embed in your HTML...is that HTML you have directly in PowerApps to send an email or something? (meaning not via Flow)

NetlogixBI
Level: Powered On

Re: Problem with Add Image Control and appres//blobmanager

Hi Rebeccas,

 

I want to convert the html to pdf then send it as an email.

 

 

Helpful resources

Announcements
firstImage

Microsoft Business Applications Virtual Launch Event

Join us for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

firstImage

Demo Extravaganza Championship Voting Open

Voting Ends: October 30, 2019!

firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

FirstImage

Power Platform World Tour

Coming to a city near you

thirdimage

PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

FourthImage

Join PowerApps User Group!!

Connect, share, and learn with your peers year-round

Top Kudoed Authors
Users Online
Currently online: 372 members 4,914 guests
Please welcome our newest community members: