cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
bmothershead
Level: Powered On

Server Response: Principal user is missing prvRead[Entity] privilege - data doesn't load

I've added new users to the PowerApp and while they have the correct permissions enabled (i.e., they're designated as a CDS user in Dynamics), when the user loads the PowerApp they encounter the message: "An error occurred on the server. Server Response: Principal user (Id=<userid>, type=8, accessMode=1, roleCount=2) is missing prvReadAccount privilege (Id=<id>)" and nothing loads in the app. The error messages flash frequently and cycle through all of the other entities, both standard (e.g., Account, Contact) and custom and then eventually stop, but still no data loads. As you can see in the attached screenshot, users are able to view the structure of the app but there's just no data present. Other users have no problems, despite having the exact same roles and permissions. I've tried revoking then regranting privileges, as well as designating the new users as System Administrators, but nothing works. Is this a known issue and how can I fix it? powerapp cds privileges error.PNG

3 REPLIES 3
Community Support Team
Community Support Team

Re: Server Response: Principal user is missing prvRead[Entity] privilege - data doesn't load

Hi @bmothershead,

Based on the error message that you provided, I think the end user has not been assigned a proper permission to access your CDS Entity.

When sharing an app which connects to a CDS Entity with other users, you must also ensure that the users who will run it have the appropriate permissions for the entity. You must firstly define a security role which has proper permission to perform tasks such as creating, reading, writing, and/or deleting within the relevant entity, and then assign the security role to the other users.

More details about managing CDS Entity permission, please check the following article:

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/share-app#manage-entity-permissions

Please check and see if the following blog would help in your scenario:

https://community.dynamics.com/crm/b/crminogic/archive/2016/02/19/error-principal-user-is-missing-pr...

Please check if you have assigned proper security role which has enough permission to perform tasks within the specific entity to the other users.

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
bmothershead
Level: Powered On

Re: Server Response: Principal user is missing prvRead[Entity] privilege - data doesn't load

Hi Kris,

 

I do have the proper security roles assigned. All of the users have the same roles but only some are getting this error message. I have no idea why because they're identical. I think this may be a bug in PowerApps. 

Simmo86
Level: Powered On

Re: Server Response: Principal user is missing prvRead[Entity] privilege - data doesn't load

Hi, 

 

Did you ever resolve this? I have the same issue and have gone through all the help texts and assigned all roles etc. but get exactly what you get. 

 

Thanks,

 

Alex

Helpful resources

Announcements
firstImage

Microsoft Business Applications Virtual Launch Event

Join us for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

FirstImage

Power Platform World Tour

Coming to a city near you

thirdimage

PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

FourthImage

Join PowerApps User Group!!

Connect, share, and learn with your peers year-round

Top Kudoed Authors
Users Online
Currently online: 288 members 1,895 guests
Please welcome our newest community members: