cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
JamesM
Level 8

Updated flow still showing same (old) data format in PowerApps?

I had a flow which returned the following text

 

{"257","831","880"}

 

That worked. I then updated the flow to instead return

 

257,831,880

 

And as you can see below, the flow works: 

2018-12-10 11_30_45-Run History _ Microsoft Flow.png

 

However, despite re-adding the flow to the PowerApps app, the data being returned is still in the old format? Why? 

 

(Ignore the fact the numbers are different, it's the format I'm concentrating on) 

 

2018-12-10 11_32_00-Heart In Hand - Saved (Unpublished) - PowerApps.png

 

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support Team
Community Support Team

Re: Updated flow still showing same (old) data format in PowerApps?

Hi @JamesM,

 

By "re-adding the flow to the PowerApps app," did you mean that you have deleted the old Flow and then readd it back in this app? Did you delete the Flow by selecting View > Data Sources > Data > ... > Remove?

Capture.JPG

If you have deleted the flow like above, then you need to select to the element you want to associate with Flow (for example, a button).

Then click "Action" in the Ribbon, then "Flows". 

Then click the Flow you want to apply.

It'll take like 10 seconds to re-establish the datasource. 

 

Now your Flow parameters should be updated.

Note that by doing so, it'll override whatever's in the OnSelect attribute.

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

1 REPLY 1
Community Support Team
Community Support Team

Re: Updated flow still showing same (old) data format in PowerApps?

Hi @JamesM,

 

By "re-adding the flow to the PowerApps app," did you mean that you have deleted the old Flow and then readd it back in this app? Did you delete the Flow by selecting View > Data Sources > Data > ... > Remove?

Capture.JPG

If you have deleted the flow like above, then you need to select to the element you want to associate with Flow (for example, a button).

Then click "Action" in the Ribbon, then "Flows". 

Then click the Flow you want to apply.

It'll take like 10 seconds to re-establish the datasource. 

 

Now your Flow parameters should be updated.

Note that by doing so, it'll override whatever's in the OnSelect attribute.

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Helpful resources

Announcements
firstImage

Microsoft Business Applications Virtual Launch Event

Join us for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

FirstImage

Power Platform World Tour

Coming to a city near you

thirdimage

PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

FourthImage

Join PowerApps User Group!!

Connect, share, and learn with your peers year-round

Top Kudoed Authors
Users Online
Currently online: 87 members 3,350 guests
Please welcome our newest community members: