cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Microsoft Employee

user().image

Hi, I am using the User().Image function to get the logged in user's profile picture

 

1. It was showing the standard picture when I had not uploaded any profile picture.

Standard.png

 

2. Even after uploading the picture it is still the same.

 

3. On testing it on a mobile device even this standard image is not getting displayed.

 

Please fix this issue it would be really helpful, and if someone was able to render their profile picture please let me know.

8 REPLIES 8
Community Support Team
Community Support Team

Re: user().image

Hi Prachi,

 

I just got the same issue with you. I had uploaded a profile picture, in the App, I added an image and set its Image property to: User().image, the image was shown as a standard picture. I also tested it on iOS, when I opened it on iOS, the image disappeared.
You could send a feedback using the feedback icon on your App. The feedback icon is shown as a smile face.

simle.PNG
 
                                      
Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
audrieg
Level 10

Re: user().image

Ditto same issue for me. Unable to display profile images using User Image function. Sent a frown.

PowerApps Staff yfw
PowerApps Staff

Re: user().image

Hi, thank you all for reporting this. This bug is logged to our planning. We will work on fixing.

 

Thanks,

Yifei Wang [MSFT]

Shannon
Level: Powered On

Re: user().image

It has been several months since this last post and I am still unable to see anything when I use User().Image - is this still not fixed?

 

I have an office 365 image uploaded, however I notice that it doesn't show it the upper right-hand corner for all products. For example, it will display in Outlook 365 but not in PowerApps or Flow.

Anonymous
Not applicable

Re: user().image

Bumping as I was hoping to use this feature but it looks like there hasn't been any progress on this bug?

KREI_CZ
Level: Powered On

Re: user().image

Hello, any update please?

Still doesnt work for me.

StephenPort
Level: Powered On

Re: user().image

Hi all here's a quick fix for this issue. I had the same problem where the image would pulln through for some but not all users.

 

  1. Connect to a new data source
  2. Choose Office365Users
  3. Insert the following code into the image object to replace User().image

 

Office365Users.UserPhoto(Office365Users.UserProfile(User().Email).Id)

 

Hope this works, it did for me

Highlighted
amac44
Level: Powered On

Re: user().image

I think this can be simplified to: Office365Users.UserPhoto(User().Email) ... at least it works for me. I also see a UserPhotoV2 function. Any idea what the difference is?

Helpful resources

Announcements
firstImage

PowerApps Monthly Community Call!

Join us next Wednesday for our Demo Extravaganza, October 16, 2019 8am PDT.

firstImage

Microsoft Business Applications Virtual Launch Event

Join us for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

FirstImage

Power Platform World Tour

Coming to a city near you

thirdimage

PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

FourthImage

Join PowerApps User Group!!

Connect, share, and learn with your peers year-round

SecondImage

Power Platform Summit North America

Register by September 5 to save $200

Top Kudoed Authors
Users Online
Currently online: 144 members 4,430 guests
Please welcome our newest community members: