cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
kgreen8790
Advocate II
Advocate II

How to add PVA Chatbot to Chat Created by Power Automate Flow Bot

debug1.PNGdebug2.PNGdebug3.PNGI'm trying to use the preview feature for posting as the Power Virtual Agent in a chat. I have the power automate flow bot create a group chat with several users then use the "post a message in chat or channel" TEAMS connector with post as PVA selected. However, the post a message connector eventually times out after multiple failed attempts with error "internal server error". My best guess is that since the PVA wasn't added when the chat was created it can't post a message in that chat but I have no idea how to add the PVA to the chat with Power Automate. As far a I know the bot doesn't have an email address or UPN to be able to add to the "participants" field of the create a chat connector. Any idea how one would accomplish this? TIA

1 ACCEPTED SOLUTION

Accepted Solutions
Expiscornovus
Super User
Super User

Hi @kgreen8790,

 

First of all it is maybe good to know that pro-active messages can only be posted to a single user in a personal chat with the bot:

https://docs.microsoft.com/en-us/power-virtual-agents/teams/advanced-proactive-message-teams#known-l...

 

If you want to send it to multiple recipients you can use the workaround which is also described in that Microsoft Doc:

https://docs.microsoft.com/en-us/power-virtual-agents/teams/advanced-proactive-message-teams#send-pr...

 

Secondly, Post In requires you to select the type of message (Chat with bot, Channel or Group Chat). I see you used that field to refer to the Conversation ID. The action cannot handle this, this is why you are getting the internal server error.

 

Below would be a configuration which should work to interact with your bot.

 

chatwithbot.PNG

 

 



Happy to help out! 🙂

Interested in more #PowerAutomate #SharePointOnline or #PowerVirtualAgents content?
Visit my blog, Subscribe to my YouTube channel or Follow me on Twitter


View solution in original post

1 REPLY 1
Expiscornovus
Super User
Super User

Hi @kgreen8790,

 

First of all it is maybe good to know that pro-active messages can only be posted to a single user in a personal chat with the bot:

https://docs.microsoft.com/en-us/power-virtual-agents/teams/advanced-proactive-message-teams#known-l...

 

If you want to send it to multiple recipients you can use the workaround which is also described in that Microsoft Doc:

https://docs.microsoft.com/en-us/power-virtual-agents/teams/advanced-proactive-message-teams#send-pr...

 

Secondly, Post In requires you to select the type of message (Chat with bot, Channel or Group Chat). I see you used that field to refer to the Conversation ID. The action cannot handle this, this is why you are getting the internal server error.

 

Below would be a configuration which should work to interact with your bot.

 

chatwithbot.PNG

 

 



Happy to help out! 🙂

Interested in more #PowerAutomate #SharePointOnline or #PowerVirtualAgents content?
Visit my blog, Subscribe to my YouTube channel or Follow me on Twitter


Helpful resources

Announcements
Power Virtual Agents News & Announcements

Power Virtual Agents News & Announcements

Keep up to date with current events and community announcements in the Power Virtual Agents community.

Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Power Virtual Agents Community Blog

Power Virtual Agents Community Blog

Check out the latest Community Blog from the community!

Top Solution Authors
Top Kudoed Authors
Users online (3,256)