cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
kgreen8790
Advocate II
Advocate II

List rows present in a table doesn't work if an item has a letter in it

My chatbot calls a flow for "list rows present in a table" to do an inventory search which works well as long as the part number doesn't contain any letters, but when the part number starts with a letter it throws an error (see images attached to this post for specific error). I made sure that the chatbot is passing in a "string" variable and verified that it is identifying it as a string in the flow also so why is it throwing the error if a letter is present? I thought a string variable would accept any characters regardless of type. Any help with this would be greatly appreciated.debug1.PNGdebug2.PNG

1 ACCEPTED SOLUTION

Accepted Solutions
Todd2
Microsoft
Microsoft

Have you tried putting quotation marks around the "G25661"?  Since it is a string, this might help. 

View solution in original post

2 REPLIES 2
Todd2
Microsoft
Microsoft

Have you tried putting quotation marks around the "G25661"?  Since it is a string, this might help. 

I did try double quotes but that failed also. However, after your suggestion I gave it another try with single quotes and this worked just fine. Thank you.

Helpful resources

Announcements
Power Virtual Agents News & Announcements

Power Virtual Agents News & Announcements

Keep up to date with current events and community announcements in the Power Virtual Agents community.

Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Power Virtual Agents Community Blog

Power Virtual Agents Community Blog

Check out the latest Community Blog from the community!

Top Solution Authors
Top Kudoed Authors
Users online (3,650)