cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Matthew5
Advocate II
Advocate II

Markdown Table Incorrect Format

Hi there, 

I've created markdown tables in the past which have worked perfectly, I'm struggling to get this one to format correctly though... this has happened before and it's been an issue on the Sharepoint list where there was an additional space and once removed worked fine. I've gone through my SharePoint list with a fine-toothed comb and there are no additional spaces anywhere. 

Is anyone familiar with other errors which cause the markdown to not be returned correctly?

Matthew5_0-1670597204724.png

 


  

1 ACCEPTED SOLUTION

Accepted Solutions
Expiscornovus
Super User
Super User

Hi @Matthew5,

 

I would use this value in the Initialize variable action:

| Links |
|-----------------|

 

And remove the first Append to string variable action, that one is not needed. Only keep the Append to string variable 2 action within the loop.



Happy to help out! 🙂

Interested in more #PowerAutomate #SharePointOnline or #PowerVirtualAgents content?
Visit my blog, Subscribe to my YouTube channel or Follow me on Twitter


View solution in original post

4 REPLIES 4
Expiscornovus
Super User
Super User

Hi @Matthew5,

 

In the message it looks like the header row and the separator row have been swapped.

 

Normally I would expect 

| Links           |
|-----------------|
| Hyperlink value |

 

Can you share a screenshot of your configuration/setup?



Happy to help out! 🙂

Interested in more #PowerAutomate #SharePointOnline or #PowerVirtualAgents content?
Visit my blog, Subscribe to my YouTube channel or Follow me on Twitter


Matthew5
Advocate II
Advocate II

Hi @Expiscornovus 

Yeah sure, any help is greatly appreciated, I may be adding in additional columns at a later date so it would be really helpful to have these links as a markdown table

 

Matthew5_0-1670856437200.pngMatthew5_1-1670856462137.png

 



Expiscornovus
Super User
Super User

Hi @Matthew5,

 

I would use this value in the Initialize variable action:

| Links |
|-----------------|

 

And remove the first Append to string variable action, that one is not needed. Only keep the Append to string variable 2 action within the loop.



Happy to help out! 🙂

Interested in more #PowerAutomate #SharePointOnline or #PowerVirtualAgents content?
Visit my blog, Subscribe to my YouTube channel or Follow me on Twitter


Kat_5
Regular Visitor

see this video 

           https://youtu.be/nSVehjJlX5I

How to correct a markdown tables it's clearly explained well and also go through the below link

            https://learn.microsoft.com/en-us/power-automate/approvals-markdown-support

 

2023-01-03.png

 

Helpful resources

Announcements
Power Virtual Agents News & Announcements

Power Virtual Agents News & Announcements

Keep up to date with current events and community announcements in the Power Virtual Agents community.

Power Virtual Agents Community Blog

Power Virtual Agents Community Blog

Check out the latest Community Blog from the community!

Top Solution Authors
Top Kudoed Authors
Users online (3,263)