cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
petermoorey
New Member

Power Automate - Changes to flow not updating in VA

I published a Power Automate flow as a solution, added it into the virtual agent topic/canvas successfully.  When I modify the flow (in the solution) the inputs/outputs are always the default 1 string, 1 number in/out.  I tried adding/removing the Power Automate flow in the canvas.  

 

Please can someone confirm why changes in Power Automate are not reflected in Power Virtual Agent? 

1 ACCEPTED SOLUTION

Accepted Solutions
CleberM
PVA
PVA

Hey @petermoorey ,

 

The changes should be pretty fast once you save the flow.

 

What I've missed before, and might be your issue, is that you have to change both the Response to PVA's "Body" AND "Response Body JSON" sections in the flow. See the two highlighted sections on the attached screenshot.

 

Let us know if that was your case. 

View solution in original post

3 REPLIES 3
CleberM
PVA
PVA

Hey @petermoorey ,

 

The changes should be pretty fast once you save the flow.

 

What I've missed before, and might be your issue, is that you have to change both the Response to PVA's "Body" AND "Response Body JSON" sections in the flow. See the two highlighted sections on the attached screenshot.

 

Let us know if that was your case. 

View solution in original post

@CleberMthanks, that was exactly the issue!

nmk
Resolver I
Resolver I

I don't think this feature is still available. Struggling....

Helpful resources

Announcements
March Update

Welcome to the User Group Private Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Top Solution Authors
Top Kudoed Authors
Users online (12,681)