cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
AccuFloDev
Level: Powered On

App broken this AM - OwnerId column no longer loading into CDS for Apps Entities

Hello,

 

I have been developing an app over the past few weeks that seems to be continuously hampered by random issues from server-side changes.

 

Today, I'm attempting to load an app that was working as of last Thursday, but is now broken because a column I use to filter items with (OwnerId), no longer loads into my PowerApp entities! (Common Data Service for Apps Instance Version: 9.1.0.1087)

 

I am using the OwnerId column instead of the 'Created By' or 'Modified By' column to filter items that belong to a specific user (so that changes to an entity by another party don't make it invisible to the owner).

Is there any reason why this was removed? Is there something I can do to get it back?

4 REPLIES 4
AbeSaldana
Level: Powered On

Re: App broken this AM - OwnerId column no longer loading into CDS for Apps Entities

ownerId is a special lookup control in Dynamics 365 CE and is similar to Customer Control, the owner can be a user (Systemuser) or a Team record, the issue most of the time you need to validate that the ownerid is a user or a team and then update the records for import, making sure you have the user or the Team in your target organization.

 

This is a common issue when using complex controls, like owner and customers

 

hope this help you. 

 

Abe.

 

AccuFloDev
Level: Powered On

Re: App broken this AM - OwnerId column no longer loading into CDS for Apps Entities

Hey @AbeSaldana,

 

My issue is not that I don't understand the column, it's that it is no longer showing up as a selectable column on Entities.  It looks like something was changed on the experimental connector that removed it.

MichelGueli
Level: Powered On

Re: App broken this AM - OwnerId column no longer loading into CDS for Apps Entities

Any update on this?

Highlighted
AccuFloDev
Level: Powered On

Re: App broken this AM - OwnerId column no longer loading into CDS for Apps Entities

Hey @MichelGueli,

 

From my tests this issue appears to be occuring only for the CDS Experimental Connector feature.
And no, I have not received a response from Microsoft on this at all.

Helpful resources

Announcements
firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

SecondImage

PowerApps Monthly Community Call

Next Wednesday, August 21st at 8am PDT

Top Community Contributors for July 2019

Top Community Contributors for July 2019

Let's thank our top community contributors

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

FirstImage

Power Platform World Tour

Coming to a city near you

thirdimage

PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

FourthImage

Join PowerApps User Group!!

Connect, share, and learn with your peers year-round

FifthImage

Dynamics 365 and Power Platform April 2019 Release notes

Features releasing from April 2019 through September 2019!

SixthImage

Power Summit Australia 2019

August 20-23rd 2019

Users Online
Currently online: 18 members 4,262 guests
Please welcome our newest community members: