cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Manish-Sharma
Level: Power Up

Business Central webservice not apprearing in Power Apps

Hi All,

I have define 2 webservices in business central to connect with Power Apps i.e.

Object type     Object ID      Object Name                    

Page                 1328            Create Purchase Order

Page                  9307            Purchase Orders

 

But, when i go to connect Power Apps with business central, i can only see the std. webservice (tables) in the list. 

Can't find purchase order anywhere. please suggest if i'm missing something.

 

thanks

 

 

3 REPLIES 3
Highlighted
Community Support Team
Community Support Team

Re: Business Central webservice not apprearing in Power Apps

Hi @Manish-Sharma ,

Currently, I could not reproduce your issue on my side.

 

Please check if you have chosen a proper instance (dataset) when you create a connection from PowerApps to your D365 Business Central data source.

 

Please also check if the std. webservice (tables) and your Purchase Order webservice are in same Business Central instance. If not, please re-create a new connection to your corresponding Business Central instance from your PowerApps.

 

More details about creating a connection from PowerApps to Business Central, please check the following video:

https://www.youtube.com/watch?v=HKT6OsH2SXw

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
benedictmayor
Level: Powered On

Re: Business Central webservice not apprearing in Power Apps

Has this been resolved? I am also encountering the same problem.

Fvilar
Level: Powered On

Re: Business Central webservice not apprearing in Power Apps

I have also encountered the same problem.

 

I have created a new Table in business central. I have also create a List Page and I have define 1 new webservices to connect with Power Apps, but it isn't appearing with the connections standard when i try to connect.

 

However, if I have changed the Id Object of one of the standard webservices, for the Id of my new page and it works, but I'm sure that there are a better solution to create the connection.

Helpful resources

Announcements
Better Together’ Contest Finalists Announced!

'Better Together’ Contest Finalists Announced!

Congrats to the finalists of our ‘Better Together’-themed T-shirt design contest! Click for the top entries.

thirdimage

Power Apps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Join THE global Microsoft Power Platform event series

Attend for two days of expert-led learning and innovation on topics like AI and Analytics, powered by Dynamic Communities

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

thirdimage

Microsoft Business Applications Virtual Launch

Join us for the Microsoft Business Applications Virtual Launch Event on Thursday, April 2, 2020, at 8:00 AM PST.

thirdimage

Community Summit North America

Innovate, Collaborate, Grow - The top training and networking event across the globe for Microsoft Business Applications

Users online (4,686)