cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Manish-Sharma
New Member

Business Central webservice not apprearing in Power Apps

Hi All,

I have define 2 webservices in business central to connect with Power Apps i.e.

Object type     Object ID      Object Name                    

Page                 1328            Create Purchase Order

Page                  9307            Purchase Orders

 

But, when i go to connect Power Apps with business central, i can only see the std. webservice (tables) in the list. 

Can't find purchase order anywhere. please suggest if i'm missing something.

 

thanks

 

 

3 REPLIES 3
Community Support
Community Support

Re: Business Central webservice not apprearing in Power Apps

Hi @Manish-Sharma ,

Currently, I could not reproduce your issue on my side.

 

Please check if you have chosen a proper instance (dataset) when you create a connection from PowerApps to your D365 Business Central data source.

 

Please also check if the std. webservice (tables) and your Purchase Order webservice are in same Business Central instance. If not, please re-create a new connection to your corresponding Business Central instance from your PowerApps.

 

More details about creating a connection from PowerApps to Business Central, please check the following video:

https://www.youtube.com/watch?v=HKT6OsH2SXw

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
benedictmayor
Regular Visitor

Re: Business Central webservice not apprearing in Power Apps

Has this been resolved? I am also encountering the same problem.

Fvilar
Regular Visitor

Re: Business Central webservice not apprearing in Power Apps

I have also encountered the same problem.

 

I have created a new Table in business central. I have also create a List Page and I have define 1 new webservices to connect with Power Apps, but it isn't appearing with the connections standard when i try to connect.

 

However, if I have changed the Id Object of one of the standard webservices, for the Id of my new page and it works, but I'm sure that there are a better solution to create the connection.

Helpful resources

Announcements
secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

firstImage

New Ranks and Rank Icons released on April 21!

The time has come: We are finally able to share more details on the brand-new ranks coming to the Power Apps Community!

Users online (6,312)