cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
cworkman
Level: Powered On

Did the SQL Server Connector change?

Did the SQL Server Connector change? I've been unsuccessful in using my gateway to create a windows authentication SQL connection, but all my previously created connectors are working perfectly fine. 

 

I also noticed a difference in the UI itself -

 

The new SQL connector is missing the How do you want to connect to your data? question.

 

The error I'm receiving on the new connector is the following:

 

Credentials are missing or not valid. inner exception: The credentials provided for the SQL source are invalid. (Source at server;database.) clientRequestId: a29f3656-9537-4218-b034-50561f5a535e

 

Is there any documentation on the changes the PowerApps product team has made to the SQL Connector?

 

Thanks,
Channing

3 REPLIES 3
Community Support Team
Community Support Team

Re: Did the SQL Server Connector change?

Hi @cworkman ,

 

After some research, it seems that I cannot find others reporting any similar issue. And there is no offical announcements about changes for SQL connection in PowerApps. Below is the What's new blog page:

https://powerapps.microsoft.com/en-us/blog/category/new-features/

 

Is this issue happening when you try to create a new SQL server connection? Have you created the SQL server connection successfully before in PowerApps? In other words, do you have old SQL server connection that is working in your connection list?

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
cworkman
Level: Powered On

Re: Did the SQL Server Connector change?

Mona,

 

Thanks for diving into this. Yes, I currently have 3 old SQL Connections to my PowerApps applications that connect perfectly fine and are currently in use. If you see in my original post I actually took screen snippets of the old ones. They have a different UI than the new ones. 

 

In the old connections it asks you how you want to connect your data (I'm using an on-premise gateway) the server name, the database name, and then your credentials and authentication type.

 

In the new one (the only SQL Server connection under connections) it asks authentication type, server name, database name, credentials, and then you select the gateway. 

 

Completely different user interface in the current connection and it returns a credential error which I know is wrong because my current SQL connections are connected with the exact same credentials and gateway. 

 

Thanks,

Channing

 

 

cworkman
Level: Powered On

Re: Did the SQL Server Connector change?

Misspelled the database name - kicking myself in the head as we speak. Thanks for the support!

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Users Online
Currently online: 145 members 5,031 guests
Please welcome our newest community members: