cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Leidt
Frequent Visitor

Expecting a record value

Hello all,

 

I'm new on the platform and I'm trying some stuff out. So I've a submit button that when clicked submits data to a CDS. (entity: Armatuur)

 

But i can't seem to figure out how i can solve the error.. Any suggestions how to fix the error?

 

Thanks you in advance!

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support
Community Support

Re: Expecting a record value

Hi @Leidt ,

Could you please share a bit more about the Entity the cr6c4_Armatuurtypebatterij (LookUp field) column references values from?

Could you please share more details about the formula within the Items property of the ComboBox3_2?

 

Based on the issue that you mentioned, I think there is something wrong with the formula you provided. I have made a test on my side, please take a try with the following workaround:9.JPG

On your side, please consider set the Items property of the ComboBox3_2 to folowing formula:

Choices(Armatuurs.cr6c4_Armatuurtypebatterij)    /* <-- Or Choices(Armatuurs.'Armatuur type + batterij') */

then modify your Patch formula as below:

Patch(
          Armatuurs,
          Defaults(Armatuurs),
          {
             cr6c4_Armatuurtypebatterij: ComboBox3_2.Selected
          }
)

Please consider take a try with above solution, check if the issue is solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

2 REPLIES 2
Leidt
Frequent Visitor

Re: Expecting a record value

Additional information about my entity > Armatuur

Community Support
Community Support

Re: Expecting a record value

Hi @Leidt ,

Could you please share a bit more about the Entity the cr6c4_Armatuurtypebatterij (LookUp field) column references values from?

Could you please share more details about the formula within the Items property of the ComboBox3_2?

 

Based on the issue that you mentioned, I think there is something wrong with the formula you provided. I have made a test on my side, please take a try with the following workaround:9.JPG

On your side, please consider set the Items property of the ComboBox3_2 to folowing formula:

Choices(Armatuurs.cr6c4_Armatuurtypebatterij)    /* <-- Or Choices(Armatuurs.'Armatuur type + batterij') */

then modify your Patch formula as below:

Patch(
          Armatuurs,
          Defaults(Armatuurs),
          {
             cr6c4_Armatuurtypebatterij: ComboBox3_2.Selected
          }
)

Please consider take a try with above solution, check if the issue is solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Helpful resources

Announcements
secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

firstImage

New Ranks and Rank Icons released on April 21!

The time has come: We are finally able to share more details on the brand-new ranks coming to the Power Apps Community!

Users online (7,024)