cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Microsoft
Microsoft

Fields Not Syncing in App Form

I am trying to add and remove fields from my CDS entity and this works fine in the data tab. When I go the form which is using this as a data source in my app, these fields don't update. If I removed one, it still shows in the list of available fields to show in the form properties. If I add a new one it doesn't show up as an option.

 

I have tried refreshing, logging out and logging back in - nothing seems to update these. Why is this out of sync and what can I do to fix it?

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Microsoft
Microsoft

Re: Fields Not Syncing in App Form

I ended up solving this by just removing the data source from the app and adding it again - not ideal, but glad to find some workaround 

View solution in original post

5 REPLIES 5
Highlighted
Super User II
Super User II

Re: Fields Not Syncing in App Form

I assume by app you're referring to a canvas app and not a model-driven app? Have you tried the following tip: https://crmtipoftheday.com/1369/new-user-cannot-see-environment/

Highlighted
Microsoft
Microsoft

Re: Fields Not Syncing in App Form

@EricRegnier - thanks for the response, I have been able to see the environments and entities the whole time - this seems to be an issue with the fields within the entities not updating. This causes huge issues because some of the deleted fields were required - it tells me I need to use them, then gives an error when I submit the form because these don't exist in the actual entity. 

Highlighted
Super User II
Super User II

Re: Fields Not Syncing in App Form

Even though you can still see the environments, try that to see if not some kind of server cache issue.

Also, try going to flow.Microsoft.com, create a flow with the connector and see if you see the removed fields. Hope that can also help to invalidate the cache.

Highlighted
Microsoft
Microsoft

Re: Fields Not Syncing in App Form

okay, I'll give it a try!

Highlighted
Microsoft
Microsoft

Re: Fields Not Syncing in App Form

I ended up solving this by just removing the data source from the app and adding it again - not ideal, but glad to find some workaround 

View solution in original post

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Come join us today! Find your favorite faces from the community presenting at the Power Platform Community Conference!

Watch Now

Experience what’s next for Power Apps

See the latest Power Apps innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Users online (3,490)