cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
OnLineO
Level: Power Up

Re: Help with LookUp Columns - CDS Entities returning null data for lookups in PowerApps

Hello,

For 2 days I try to understand why I cannot make any lookups running. I use a Community environment.

I learned using Northwind sample, it runs perfectly, and I use this fantastic sample to build my own Canvas. The CDS model is built in and unfortunately it is not described.

With my own-built so a simple CDS model as 2 entities and only one lookup, it doesn't run ! The 1-N relationship is automatically created, I can see it in both entities. But when I add the lookup field in an Edit View, the associated Choices returns an error and if I edit the field of the datacard, in the Data panel no layout is selected and the SearchField is empty and greyed. Sometimes I also see the Primary Field option, but also greyed.

Any idea where I must do an enormous mistake ?

Many Thanks

Christian

PytByt
Level: Powered On

Re: Help with LookUp Columns - CDS Entities returning null data for lookups in PowerApps

Hi @TimRohr 

I'm trying both expression to pull data from CDS into my Gallery items, and i still get Blank.

 

1. Set(vEditRespondRadio, First(Filter('SMU_ Service Lines', Key = LabelKeyEditInspection.Text)).Responds);

2. Set(vEditRespondRadio, LookUp('SMU_ Service Lines', Key = LabelKeyEditInspection.Text).Responds);

What should i do? 

 

Thanks.

pytbyt

Highlighted
KelvinBox
Level: Powered On

Re: Help with LookUp Columns - CDS Entities returning null data for lookups in PowerApps

Assuming it's the same lookup/foreign key issue, drop a label outside the gallery and set the text to the following:

 

First('SMU_ Service Lines').Responds

 

This should kick CDS into returning the related data to you.  If it works just make the label invisible and leave it there until the issue gets officially fixed.

PytByt
Level: Powered On

Re: Help with LookUp Columns - CDS Entities returning null data for lookups in PowerApps

Hi @KelvinBox 

I made a new post regarding my problem in here. Please take a look. I really need helps.

 

I tried your expression:
Set(vEditRespondRadio, First('SMU_ Service Lines').Responds);

And it did work, but it not meet my requirement for get the whole value from CDS into my Gallery items like below:
pull cds 2.pngI need to fill all the gallery items based on CDS data

That is why i'm using the lookup formula at the firs place to get the exact data value from the CDS to each Gallery Items.
Set(vEditRespondRadio, LookUp('SMU_ Service Lines', Key = LabelKeyEditInspection.Text).Responds);

Is there any work around you can give?

Thanks.

BR,

pytbyt

jzcase
Level: Powered On

Re: Help with LookUp Columns - CDS Entities returning null data for lookups in PowerApps

I can't wait for the CDS connector to be fixed. Going back to the Dynamics 365 connector. The code is jankier but at least it performs.

 

Dear Microsoft: Please label the CDS Connector as PREVIEW ONLY because it is not production ready. I can't even get primary keys out of it - SMH.

KelvinBox
Level: Powered On

Re: Help with LookUp Columns - CDS Entities returning null data for lookups in PowerApps


@jzcase wrote:

Reporting same problem here. Not just LookUp() but also ClearCollect() pulls null values for lookup fields! Ridiculous!


Had the ClearCollect issue confirmed by MS as current behaviour for CDS v2 connector.  You need to navigate the lookup property prior to ClearCollect in order to get the lookups to populate.  

 

A label on the form with "First(<entity name>).<LookupField>.<Related Field>" will cause the ClearCollect to work.

AccuFloDev
Level: Powered On

Re: Help with LookUp Columns - CDS Entities returning null data for lookups in PowerApps

Wow, this thread's still alive... almost a year after it was made.

Anyway, I'm posting to confirm that as of August 27, 2019 I am still seeing this issue with CDS datasources and lookups.

I have a form connected to a CDS entity with 2 lookups - when I load my app it will sometimes grab the values of both, but usually only 1 or the other and sometimes neither.  I can't find any information on how to make it grab this information consistently beyond the hack with the labels...which is both confusing and makes the app a lot harder to maintain (Thanks to @KelvinBox for providing a workaround).

Any update from the PowerApps team on this?  Is this being tracked internally?

KelvinBox
Level: Powered On

Re: Help with LookUp Columns - CDS Entities returning null data for lookups in PowerApps


@KelvinBox wrote:

@jzcase wrote:

Reporting same problem here. Not just LookUp() but also ClearCollect() pulls null values for lookup fields! Ridiculous!


Had the ClearCollect issue confirmed by MS as current behaviour for CDS v2 connector.  You need to navigate the lookup property prior to ClearCollect in order to get the lookups to populate.  

 

A label on the form with "First(<entity name>).<LookupField>.<Related Field>" will cause the ClearCollect to work.


An issue with using "First" however is that it returns the first page of results from the entity just to get the first record. For my app this was a 1.4MB hit prior to the ClearCollect just to get the Lookups to work properly. On a mobile device....not good.

 

KelvinBox
Level: Powered On

Re: Help with LookUp Columns - CDS Entities returning null data for lookups in PowerApps


@AccuFloDev wrote:

Wow, this thread's still alive... almost a year after it was made.

Anyway, I'm posting to confirm that as of August 27, 2019 I am still seeing this issue with CDS datasources and lookups.

I have a form connected to a CDS entity with 2 lookups - when I load my app it will sometimes grab the values of both, but usually only 1 or the other and sometimes neither.  I can't find any information on how to make it grab this information consistently beyond the hack with the labels...which is both confusing and makes the app a lot harder to maintain (Thanks to @KelvinBox for providing a workaround).

Any update from the PowerApps team on this?  Is this being tracked internally?


Can you post the exact code you are using and screenshots?

 

I've spent a bit of time talking to the PowerApps product team about this and it's something they are aware of and working on but it's meant to only be an issue when using ClearCollect.  There is meant to be an update coming out in about 3 weeks (they wouldn't confirm an exact date) that is meant to address some of these issues.

 

AccuFloDev
Level: Powered On

Re: Help with LookUp Columns - CDS Entities returning null data for lookups in PowerApps

 


@KelvinBox wrote:


Can you post the exact code you are using and screenshots?

 

I've spent a bit of time talking to the PowerApps product team about this and it's something they are aware of and working on but it's meant to only be an issue when using ClearCollect.  There is meant to be an update coming out in about 3 weeks (they wouldn't confirm an exact date) that is meant to address some of these issues.

 


Thanks for the update @KelvinBox , it's good to know this issue is finally getting attention, though I really wish Microsoft would engage more on the CDS forums, why are we learning this information from other users and not the reps themselves? 

In regards to my issue, I'm trying to improve performance of an app by making it work mostly offline until the user initiates a sync on demand. 

As part of this, the app caches active records, dropdowns, option sets, etc. when the app is connected on startup.   My issue is that the active records have a few lookups which aren't being collected consistently on the app's sync screen.

I will give your label workaround a shot and see if that helps, if I'm still stuck then I will post the screenshots and code.

Helpful resources

Announcements
firstImage

PowerApps Monthly Community Call!

Join us next Wednesday for our Demo Extravaganza, October 16, 2019 8am PDT.

firstImage

Microsoft Business Applications Virtual Launch Event

Watch the event on demand for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

Top Community Contributors for September  2019

Top Community Contributors for September 2019 🎉🎉

Let's thank our top community contributors

firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

FirstImage

Power Platform World Tour

Coming to a city near you

thirdimage

PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

FourthImage

Join PowerApps User Group!!

Connect, share, and learn with your peers year-round

Users Online
Currently online: 513 members 6,164 guests
Please welcome our newest community members: